[U-Boot-Users] Marvell DB64460-BP I2C_BOOT/Swap_BOOT Issue

Sam Song samsongshu at yahoo.com.cn
Thu Mar 16 05:50:34 CET 2006

Hi all,

I tried booting the target with I2C_BOOT disabled
and failed - No any serial output. Then I programmed
the same image on the Large Flash area 0xf4f00000 and
inserted JP46 to swap 8-bit Boot Source to 32-bit
Boot Source. I got the following output:

U-Boot 1.1.3 (Mar 16 2006 - 09:12:14)--Marvell DB64460

CPU:   MPC7447A v1.1 @ 1396.500 MHz
BOARD: DB64460
DRAM:  SPD Checksum ok!
-- DIMM1 has 1 banks
-- DIMM2 has 0 banks
ECC Initialization of Bank 0: PASS
CAS Latency = 2.5 tRP = 3 tRAS = 6 tRCD=3
*** ONLY the first 256MB DRAM memory are used out of
the 512MB

Sure, I did some changes on CPU type detection
and clock setting only to make it work with 
I2C_BOOT enabled.

1. How to make I2C_BOOT disable case work? If 
   would better with 8-bit default boot FLASH.
2. Anyone tried booting Swap BOOT successful on this




More information about the U-Boot mailing list