[U-Boot-Users] U-Boot on simulated at91rm9200/ep7312 boards (skyeye)

Rohit rohits79 at gmail.com
Thu Mar 30 12:30:11 CEST 2006


Skyeye wiki shows howto load u-boot on the pc emulator. I have been trying
to do the same for the at91rm9200 board on my pc but am getting no success.
I am therefore sending this mail to both the skyeye-developers and
u-boot-users list. I would appreciate if you could suggest some inputs as
this is my very first hands on with both the (should i say?) applications.

Input/output is ignored at the boot prompt for the at91rm9200 board
(1) I have had success loading u-boot for ep7312 board via skyeeye emulator
while the u-boot for at91rm9200 simply doesn't takes any key strokes
whatsoever at the boot prompt.

The only difference between the two u-boot config files is that the
following three lines are not present in ep7312 board config. As am on
emulation mode i have set USART0 instead of DBGU for the at91rm9200 board


When i run the skyeye with this config i get the following
In:    serial
Out:   serial
Err:   serial
(I get the same message for ep7312 board but the input is actually
/dev/stdin and output/err is /dev/stdout)

The keystrokes are simply ignored at the boot prompt. I tried the followoing
skyeye configuration
uart: fd_in=/dev/stdin, fd_out=/dev/stdout so atleast i could redirect the
serial input output via stdin/stdout. But this didn't help me either.

This is really annoying as i can see the skyeye emulator working but am
unable to how to redirect the input/output. Any guesses?

Networking issue with ep7312 u-boot.bin and skyeye
(2) the u-boot for ep7312 board which loads fine has the following
#define CONFIG_ETHADDR          0:4:3:2:1:f

and skyeye.conf defines
net: state=on, type=vnet,base=0xfffa0000, size=0x20,int=16,
mac=0:4:3:2:2:f,  ethmod=tuntap, hostip=

When i run the skyeye emulator, u-boot boots fine and shows me the prompt. I
could see a new virtual network interface present and can ping the new
virtual host as well. But, when i do a tftpboot the boot prompt simply
hangs. The tftp logs doesn't shows any file request either

SKYEYE: If you have ELF kernel file, please use -e option to indicate your
ELF format kernel filename
SKYEYE: If you only have kernel binary image, you should put the filename of
kernel binary image in skyeye.conf file
arch: arm
cpu info: armv4, arm720t, 41807200, ffffff00, 1
mach info: name ep7312, mach_init addr 0x8068030
uart info: input device is /dev/stdin, fd is 4.
uart info: output device is /dev/stdout, fd is 5.
ethmod num=1, mac addr=0:4:3:2:2:f, hostip=
SKYEYE: use arm7100 mmu ops
Loaded RAM   ./u-boot.bin

U-Boot 1.1.4 (Mar 30 2006 - 15:19:26)
U-Boot code: C0F80000 -> C0F952F0  BSS: -> C0F99820
RAM Configuration:
Bank #0: c0000000 16 MB
Flash: 16 MB
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
EP7312 #
EP7312 #
EP7312 # tftpboot
CS8900 Ethernet chip not found?!
*** Warning: no boot file name; using '0A000002.img'
TFTP from server; our IP address is
Filename '0A000002.img'.
Load address: 0xc0500000
Loading: *
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.denx.de/pipermail/u-boot/attachments/20060330/a5d67992/attachment.htm 

More information about the U-Boot mailing list