[U-Boot-Users] u-boot delay on OMAP2430 SDP

sandeep prabhu sandeep.mitian at gmail.com
Sun Jan 21 15:07:41 CET 2007


I am using the "u-boot_16.3.tar.gz" ( u-boot version 1.1.4 ) sources
downloaded from the "linux.omap.com" site, for booting the OMAP2430 SDP board
from NOR flash. I built the sources for booting from NOR flash and burn it
using the CSST tool onto the OMAP2430 SDP board. It takes around 2 to 4
minutes for u-boot command prompt. I am also not able to boot the linux
kernel with this version.

I have tried to track exactly where is it getting delayed, as it hangs for
2-3 minutes in  function "dram_init"  in file
"board/omap2430sdp/omap2430sdp.c". But it doesnt hang at the same code
everytime I test, the problem is not consistent.
I have tried with Icache both enabling and disabling, but it did not make
any difference.

Could anyone give some pointers about what could be the issue ?

Thanks in advance,

Warm Regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.denx.de/pipermail/u-boot/attachments/20070121/daf09111/attachment.htm 

More information about the U-Boot mailing list