[U-Boot-Users] RFC: Some improvements for the FPGA subsystem
Bruce_Leonard at selinc.com
Bruce_Leonard at selinc.com
Tue Nov 13 19:15:44 CET 2007
>
> Perhaps you guys can give a little ack reply to my five FPGA patches. I
did
> not see any no-go comment on any of them, uuh.
>
> Matthias
Sorry, in my haste and stupidity I failed to read your entire original
post and see that you had patches :(.
ACK everything with the following question:
- rc = fpga_load(dev, swapdata, swapsize);
- free(swapdata);
+ rc = fpga_load(dev, dataptr, swapsize);
return rc;
I see you're using the size pulled from the BIT file rather than the size
passed into the parameter (which IMOHO is the right way to do it), but you
left the name of the variable as 'swapsize' which isn't really relevant
anymore since there's no swapping going on. I don't care since I know
what's going on, but it might be cleaner for future generations to rename
it to something more descriptive of what it really is now. Also, on a 'I
REALLY don't care' note, how much work do you think it would be to remove
the requirement of having a size on the command line for this operation?
Since the 'size' parameter is never used, I'd like to see it gone. If
it's too much work, I can do it sometime when I'm bored ;). Just a
thought.
Thanks for the work on this, saved me from having to embarrass myself by
getting patch after patch rejected 'cause I is stupid.
Bruce
More information about the U-Boot
mailing list