[U-Boot-Users] [PATCH]: Reset issue fix on mpc85xx

urwithsughosh at gmail.com urwithsughosh at gmail.com
Mon Sep 17 19:15:25 CEST 2007

  I tried the v1.3.0-rc1 on the ADS board, and problem of the board
  reset through the 'reset' command pertains. I'm still not sure about
  the reason of the MSR getting cleared, but am using a brute force

Signed-off-by: Sughosh Ganu <urwithsughosh at gmail.com>

diff --git a/cpu/mpc85xx/cpu.c b/cpu/mpc85xx/cpu.c
index 08e0468..bbc5444 100644
--- a/cpu/mpc85xx/cpu.c
+++ b/cpu/mpc85xx/cpu.c
@@ -163,7 +163,12 @@ int do_reset (cmd_tbl_t *cmdtp, bd_t *bd, int flag, int argc, char *argv[])
         * Initiate hard reset in debug control register DBCR0
         * Make sure MSR[DE] = 1
-               unsigned long val;
+               unsigned long val, msr;
+               msr = mfmsr ();
+               msr |= MSR_DE;
+               mtmsr (msr);
                val = mfspr(DBCR0);
                val |= 0x70000000;


More information about the U-Boot mailing list