[U-Boot-Users] [MIPS] Implement flush_cache()

Shinya Kuribayashi skuribay at ruby.dti.ne.jp
Tue Mar 18 19:22:53 CET 2008


Andrew Dyer wrote:
> looking at how cache_flush() is used (see common/cmd_load.c,
> common/cmd_elf.c, etc), I believe this loop should also do a cache_op
> with Hit_Invalidate_I to invalidate the icache.
> 
> seems like it would be easier to read if the condition was included in
> the while() statement

Hm, then is this ok?


diff --git a/cpu/mips/cpu.c b/cpu/mips/cpu.c
index 7559ac6..e59c9c9 100644
--- a/cpu/mips/cpu.c
+++ b/cpu/mips/cpu.c
@@ -25,6 +25,17 @@
 #include <command.h>
 #include <asm/inca-ip.h>
 #include <asm/mipsregs.h>
+#include <asm/cacheops.h>
+
+#define cache_op(op,addr)						\
+	__asm__ __volatile__(						\
+	"	.set	push					\n"	\
+	"	.set	noreorder				\n"	\
+	"	.set	mips3\n\t				\n"	\
+	"	cache	%0, %1					\n"	\
+	"	.set	pop					\n"	\
+	:								\
+	: "i" (op), "R" (*(unsigned char *)(addr)))
 
 int do_reset(cmd_tbl_t *cmdtp, int flag, int argc, char *argv[])
 {
@@ -41,6 +52,17 @@ int do_reset(cmd_tbl_t *cmdtp, int flag, int argc, char *argv[])
 
 void flush_cache(ulong start_addr, ulong size)
 {
+	unsigned long lsize = CFG_DCACHE_SIZE;
+	unsigned long addr = start_addr & ~(lsize - 1);
+	unsigned long aend = (start_addr + size - 1) & ~(lsize - 1);
+
+	while (1) {
+		cache_op(Hit_Writeback_Inv_D, start_addr);
+		cache_op(Hit_Invalidate_I, start_addr);
+		if (addr == aend)
+			break;
+		addr += lsize;
+	}
 }
 
 void write_one_tlb(int index, u32 pagemask, u32 hi, u32 low0, u32 low1)




More information about the U-Boot mailing list