[U-Boot-Users] [PATCH 2/2] Freescale eLBC FCM NAND driver
Scott Wood
scottwood at freescale.com
Tue Mar 25 18:06:00 CET 2008
Jean-Christophe PLAGNIOL-VILLARD wrote:
>> +#if defined(CONFIG_CMD_NAND) && defined(CONFIG_NAND_FSL_ELBC)
> Please move to the Makefile
OK.
>> + /* READOOB reads only the OOB because no ECC is performed. */
>> + case NAND_CMD_READOOB:
>> + vdbg("fsl_elbc_cmdfunc: NAND_CMD_READOOB, page_addr:"
>> + " 0x%x, column: 0x%x.\n", page_addr, column);
>> +
>> + out_be32(&lbc->fbcr, mtd->oobsize - column);
>> + set_addr(mtd, column, page_addr, 1);
>> +
>> + ctrl->read_bytes = mtd->writesize + mtd->oobsize;
>> +
>> + fsl_elbc_do_read(chip, 1);
>> + fsl_elbc_run_command(mtd);
>> +
> ^^^^^^^^^^^^^
> WhiteSpace please remove
Grr... I keep forgetting to enable the post-commit hook in new git
repositories. I wish it could be configured globally in a ~/.gitrc or
similar.
Of course, I also wish people wouldn't get so bent out of shape about
blank lines being indented to the level of the code around them.
>> +static void fsl_elbc_select_chip(struct mtd_info *mtd, int chip)
>> +{
>> + /* The hardware does not seem to support multiple
>> + * chips per bank.
>> + */
> please use this comment style
Do we really need such trivial style differences with the Linux driver,
which will only serve as an annoyance when keeping the two in sync, not
to mention wasting vertical space with no readability benefit because
there's pretty much always a (mostly) blank line above the comment?
>> + return i == len && ctrl->status == LTESR_CC ? 0 : -EIO;
> please use something like that to help the reading
> return ((i==len) && (ctrl->status==LTESR_CC))? 0 : -EIO;
That's not the style I've generally seen used.
-Scott
More information about the U-Boot
mailing list