[U-Boot] [PATCH V3] arm: timer and interrupt init rework
Dirk Behme
dirk.behme at googlemail.com
Sat May 16 08:11:50 CEST 2009
Jean-Christophe PLAGNIOL-VILLARD wrote:
> actually the timer init use the interrupt_init as init callback
> which make the interrupt and timer implementation difficult to follow
>
> so now rename it as int timer_init(void) and use interrupt_init for interrupt
>
> btw also remane the corresponding file to the functionnality implemented
>
> as ixp arch implement two timer - one based on interrupt - so all the timer
> related code is moved to timer.c
>
> Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj at jcrosoft.com>
ARM Cortex-A8 part
Signed-off-by: Dirk Behme <dirk.behme at googlemail.com>
...
> diff --git a/lib_arm/board.c b/lib_arm/board.c
> index 5d05d9b..37ed3e3 100644
> --- a/lib_arm/board.c
> +++ b/lib_arm/board.c
> @@ -266,7 +266,10 @@ init_fnc_t *init_sequence[] = {
> arch_cpu_init, /* basic arch cpu dependent setup */
> #endif
> board_init, /* basic board dependent setup */
> +#if defined(CONFIG_USE_IRQ)
> interrupt_init, /* set up exceptions */
> +#endif
> + timer_init, /* initialize timer */
> env_init, /* initialize environment */
> init_baudrate, /* initialze baudrate settings */
> serial_init, /* serial communications setup */
Btw.: Jean-Christophe: I'm happy that you removed the re-ordering of
boot sequence for the moment as discussed in [1] :)
Best regards
Dirk
[1] http://lists.denx.de/pipermail/u-boot/2009-May/051949.html
More information about the U-Boot
mailing list