[U-Boot] [PATCH 1/3 v5] stdio/device: rework function naming convention
Jean-Christophe PLAGNIOL-VILLARD
plagnioj at jcrosoft.com
Tue May 19 14:54:09 CEST 2009
On 12:14 Sat 16 May , Jean-Christophe PLAGNIOL-VILLARD wrote:
> actually the console API use the following naming convention
>
> ======Extract======
> typedef struct device_t;
>
> int device_register (device_t * dev);
> int devices_init (void);
> int device_deregister(char *devname);
> struct list_head* device_get_list(void);
> device_t* device_get_by_name(char* name);
> device_t* device_clone(device_t *dev);
> =======
>
> which is device generic and confusing
>
> instead of using device_XX and device_t
> we now switch to stdio_XX and stdio_dev
>
> this will also allow to add later a generic device mecanism
> in order to have multi generic device support and driver instance
>
> Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj at jcrosoft.com>
> ---
ping
Best Regards,
J.
More information about the U-Boot
mailing list