[U-Boot] [PATCH v3 3/3] ppc/85xx: Clean up mpc8572DS PCI setup code
Paul Gortmaker
paul.gortmaker at windriver.com
Sun Sep 20 23:26:24 CEST 2009
On Sat, Sep 19, 2009 at 1:08 PM, Kumar Gala <galak at kernel.crashing.org> wrote:
> Use new fsl_pci_init_port() that reduces amount of duplicated code in the
> board ports, use IO accessors and clean up printing of status info.
>
> Signed-off-by: Kumar Gala <galak at kernel.crashing.org>
> ---
> * Fixed set_bits32 -> setbits_be32
You got the bottom one, but it looks like you missed converting the 1st two.
Paul.
>
> board/freescale/mpc8572ds/mpc8572ds.c | 226 ++++++++++----------------------
> 1 files changed, 71 insertions(+), 155 deletions(-)
[...]
> #else
> gur->devdisr |= MPC85xx_DEVDISR_PCIE3; /* disable */
> #endif
>
[...]
> #else
> gur->devdisr |= MPC85xx_DEVDISR_PCIE2; /* disable */
> #endif
[...]
> #else
> - gur->devdisr |= MPC85xx_DEVDISR_PCIE; /* disable */
> + setbits_be32(&gur->devdisr, MPC85xx_DEVDISR_PCIE); /* disable */
> #endif
More information about the U-Boot
mailing list