[U-Boot] [PATCH] Rename getenv_r() into getenv_f()
Wolfgang Denk
wd at denx.de
Wed Aug 4 00:45:50 CEST 2010
Dear Wolfgang Denk,
In message <1280001343-1460-1-git-send-email-wd at denx.de> you wrote:
> While running from flash, i. e. before relocation, we have only a
> limited C runtime environment without writable data segment. In this
> phase, some configurations (for example with environment in EEPROM)
> must not use the normal getenv(), but a special function. This
> function had been called getenv_r(), with the idea that the "_r"
> suffix would mean the same as in the _r_eentrant versions of some of
> the C library functions (for example getdate vs. getdate_r, getgrent
> vs. getgrent_r, etc.).
>
> Unfortunately this was a misleading name, as in U-Boot the "_r"
> generally means "running from RAM", i. e. _after_ relocation.
>
> To avoid confusion, rename into getenv_f() [as "running from flash"]
>
> Signed-off-by: Wolfgang Denk <wd at denx.de>
> ---
> README | 2 +-
> arch/arm/lib/board.c | 2 +-
> arch/avr32/lib/board.c | 2 +-
> arch/blackfin/lib/board.c | 2 +-
> arch/blackfin/lib/post.c | 2 +-
> arch/i386/lib/board.c | 2 +-
> arch/m68k/lib/board.c | 6 +++---
> arch/mips/cpu/incaip_clock.c | 2 +-
> arch/mips/lib/board.c | 2 +-
> arch/powerpc/cpu/mpc8xx/speed.c | 2 +-
> arch/powerpc/cpu/ppc4xx/4xx_ibm_ddr2_autocalib.c | 2 +-
> arch/powerpc/lib/board.c | 6 +++---
> arch/sparc/lib/board.c | 2 +-
> board/Marvell/db64360/mv_eth.c | 4 ++--
> board/Marvell/db64460/mv_eth.c | 4 ++--
> board/avnet/fx12mm/fx12mm.c | 2 +-
> board/cray/L1/L1.c | 2 +-
> board/dave/PPChameleonEVB/PPChameleonEVB.c | 2 +-
> board/esd/adciop/adciop.c | 2 +-
> board/esd/apc405/apc405.c | 2 +-
> board/esd/ar405/ar405.c | 2 +-
> board/esd/ash405/ash405.c | 2 +-
> board/esd/canbt/canbt.c | 2 +-
> board/esd/cms700/cms700.c | 2 +-
> board/esd/cpci2dp/cpci2dp.c | 2 +-
> board/esd/cpci405/cpci405.c | 2 +-
> board/esd/cpci750/mv_eth.c | 4 ++--
> board/esd/cpciiser4/cpciiser4.c | 2 +-
> board/esd/dasa_sim/dasa_sim.c | 2 +-
> board/esd/dp405/dp405.c | 2 +-
> board/esd/du405/du405.c | 2 +-
> board/esd/du440/du440.c | 2 +-
> board/esd/hh405/hh405.c | 8 ++++----
> board/esd/hub405/hub405.c | 4 ++--
> board/esd/meesc/meesc.c | 2 +-
> board/esd/ocrtc/ocrtc.c | 2 +-
> board/esd/otc570/otc570.c | 4 ++--
> board/esd/pci405/pci405.c | 2 +-
> board/esd/plu405/plu405.c | 2 +-
> board/esd/pmc405/pmc405.c | 2 +-
> board/esd/voh405/voh405.c | 4 ++--
> board/esd/vom405/vom405.c | 2 +-
> board/esd/wuh405/wuh405.c | 2 +-
> board/evb64260/eth.c | 2 +-
> board/g2000/g2000.c | 2 +-
> board/gen860t/gen860t.c | 6 +++---
> board/inka4x0/inka4x0.c | 2 +-
> board/ip860/ip860.c | 2 +-
> board/kup/kup4k/kup4k.c | 4 ++--
> board/mpl/common/common_util.c | 4 ++--
> board/mpl/common/memtst.c | 2 +-
> board/mpl/mip405/mip405.c | 2 +-
> board/mpl/pati/pati.c | 2 +-
> board/mpl/pip405/pip405.c | 2 +-
> board/mpl/vcma9/vcma9.c | 4 ++--
> board/ppmc8260/ppmc8260.c | 2 +-
> board/prodrive/p3mx/mv_eth.c | 4 ++--
> board/sbc405/sbc405.c | 2 +-
> board/sbc8260/sbc8260.c | 2 +-
> board/siemens/CCM/ccm.c | 2 +-
> board/siemens/SCM/scm.c | 2 +-
> board/snmc/qs850/qs850.c | 2 +-
> board/snmc/qs860t/qs860t.c | 2 +-
> board/tqc/tqm8260/tqm8260.c | 2 +-
> board/trab/trab.c | 2 +-
> board/uc100/uc100.c | 2 +-
> common/cmd_nvedit.c | 2 +-
> drivers/mtd/cfi_flash.c | 2 +-
> include/common.h | 2 +-
> post/post.c | 2 +-
> 70 files changed, 89 insertions(+), 89 deletions(-)
Applied.
Best regards,
Wolfgang Denk
--
DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
Beware of the Turing Tar-pit in which everything is possible but
nothing of interest is easy.
More information about the U-Boot
mailing list