[U-Boot] [PATCH V2 0/4] Improve I2C for orion5x, kirkwood and ED Mini V2

Albert Aribaud albert.aribaud at free.fr
Fri Aug 27 02:55:28 CEST 2010


SUMMARY:

This patchset improves the driver for the Marvell TWSI interface found
on orion5x and kirkwood SoCs and adds I2C support to the orion5x-based
ED Mini V2 board. The mvtwsi driver is a complete rewrite, 50% shorter
in source code lines, 25% smaller in object size, much simpler and way
faster than the kirkwood_i2c driver it replaces.

PATCH SET:

Patch 1 removes dependencies on kirwkood_i2c from suen3, the only
board that mentioned it. Patch 2 renames the driver from kirkwood_i2c
to mvtwsi. Patch 3 replaces the old code with the new one. Patch 4
adds support for I2C in orion5x-based ED Mini V2.

TESTS:

This driver has been tested on an ED Mini V2 with basic u-boot i2c
commands, on an 5C372a RTC and an HT24LC08 1 KB eeprom (read+write).

HISTORY:

V1:	Initial submission as an addition rather than a replacement.

V2:	Fixed copyright line.
	Made mvtwsi a replacement for kirkwood_i2c.
	Made patches checkpatch-clean: 0 errors, 0 warnings.
	Various cosmetic changes.
	Removed useless i2c_end() function.

Albert Aribaud (4):
  suen3: remove CONFIG_HARD_I2C and related defines
  i2c: rename kirkwood_i2c to mvtwsi
  i2c: rewrite mvtwsi, support orion5x and kirkwood
  edminiv2: add I2C support using mvtwsi driver

 drivers/i2c/Makefile       |    2 +-
 drivers/i2c/kirkwood_i2c.c |  496 --------------------------------------------
 drivers/i2c/mvtwsi.c       |  430 ++++++++++++++++++++++++++++++++++++++
 include/configs/edminiv2.h |    9 +
 include/configs/km_arm.h   |    8 -
 5 files changed, 440 insertions(+), 505 deletions(-)
 delete mode 100644 drivers/i2c/kirkwood_i2c.c
 create mode 100644 drivers/i2c/mvtwsi.c



More information about the U-Boot mailing list