[U-Boot] [PATCH v2 0/6] TFTP server

Luca Ceresoli luca.ceresoli at comelit.it
Mon Apr 18 18:19:48 CEST 2011


Hi,
here's the tftpsrv patch series, with checkpatch warnings fixed.
Only patches 2 and 3 are actually changed. Patch 1 is unchanged and patches 4-6
have been simply rebased.

There are still a few checkpatch issues (!), though, that I think can be ignored
and I'm not going to fix unless there's a specific request.

Here they are:

> WARNING: consider using kstrto* in preference to simple_strtol
> #125: FILE: net/tftp.c:619:
> +		TftpRemotePort = simple_strtol(ep, NULL, 10);
Which is Linux-only

> WARNING: do not add new typedefs
> #61: FILE: include/net.h:367:
> +typedef enum { BOOTP, RARP, ARP, TFTP, DHCP, PING, DNS, NFS, CDP, NETCONS, SNTP,
Is a typedef *enum* considered bad in U-Boot?

Luca

Luca Ceresoli (6):
  README: remove spurious line
  NET: pass source IP address to packet handlers
  TFTP: rename "server" to "remote"
  TFTP: rename STATE_RRQ to STATE_SEND_RRQ
  TFTP: net/tftp.c: add server mode receive
  TFTP: add tftpsrv command

 README                   |    2 +-
 common/cmd_net.c         |   14 +++++
 drivers/net/netconsole.c |    5 +-
 include/net.h            |   18 +++++--
 net/bootp.c              |    9 ++-
 net/dns.c                |    2 +-
 net/net.c                |   40 +++++++++------
 net/nfs.c                |    2 +-
 net/rarp.c               |    3 +-
 net/sntp.c               |    3 +-
 net/tftp.c               |  123 +++++++++++++++++++++++++++++++++++-----------
 net/tftp.h               |    6 ++
 12 files changed, 167 insertions(+), 60 deletions(-)



More information about the U-Boot mailing list