[U-Boot] [PATCH] updated at91sam9263 port
Remy Bohmer
linux at bohmer.net
Fri Feb 25 19:17:24 CET 2011
Hi,
2011/2/25 Uli Raich <Uli.Raich at cern.ch>:
> The at91sam9263ek port is updated to the level of the at91sam9260ek port
>
> Signed-off-by: Uli Raich <uli.raich at cern.ch>
This one is much cleaner/better compared to previous version!
Some comments I noticed at first glance below.
> --- a/board/atmel/at91sam9263ek/at91sam9263ek.c
> +++ b/board/atmel/at91sam9263ek/at91sam9263ek.c
> @@ -23,17 +23,16 @@
> */
>
> #include <common.h>
> -#include <asm/sizes.h>
> -#include <asm/arch/at91sam9263.h>
> +#include <mmc.h>
> +#include <asm/io.h>
> +#include <asm/arch/at91sam9260_matrix.h>
sam9260 matrix on a sam9263 core??
> #ifdef CONFIG_LCD
> vidinfo_t panel_info = {
> - vl_col: 240,
> - vl_row: 320,
> - vl_clk: 4965000,
> - vl_sync: ATMEL_LCDC_INVLINE_INVERTED |
> - ATMEL_LCDC_INVFRAME_INVERTED,
> - vl_bpix: 3,
> - vl_tft: 1,
> - vl_hsync_len: 5,
> - vl_left_margin: 1,
> - vl_right_margin:33,
> - vl_vsync_len: 1,
> - vl_upper_margin:1,
> - vl_lower_margin:0,
> - mmio: AT91SAM9263_LCDC_BASE,
> +vl_col: 240,
> +vl_row : 320,
> +vl_clk : 4965000,
> +vl_sync : ATMEL_LCDC_INVLINE_INVERTED | ATMEL_LCDC_INVFRAME_INVERTED,
> +vl_bpix : 3,
> +vl_tft : 1,
> +vl_hsync_len : 5,
> +vl_left_margin : 1,
> +vl_right_margin : 33,
> +vl_vsync_len : 1,
> +vl_upper_margin : 1,
> +vl_lower_margin : 0,
> +mmio : ATMEL_BASE_LCDC
Why remove indentation?
> };
> +int board_early_init_f(void)
> +{
> + struct at91_pmc *pmc = (struct at91_pmc *)ATMEL_BASE_PMC;
> +
> + /* Enable clocks for all PIOs */
> + writel((1 << ATMEL_ID_PIOA) | (1 << ATMEL_ID_PIOB) |
> + (1 << ATMEL_ID_PIOC),
> + &pmc->pcer);
> +
> + return 0;
> +}
> +
> diff --git a/include/configs/at91sam9263ek.h b/include/configs/at91sam9263ek.h
> index f6cb406..d3d22b0 100644
> --- a/include/configs/at91sam9263ek.h
> +++ b/include/configs/at91sam9263ek.h
> /* SDRAM */
> #define CONFIG_NR_DRAM_BANKS 1
> -#define PHYS_SDRAM 0x20000000
> -#define PHYS_SDRAM_SIZE 0x04000000 /* 64 megs */
> +#define CONFIG_SYS_SDRAM_BASE ATMEL_BASE_CS1
> +#define CONFIG_SYS_SDRAM_SIZE 0x04000000
Please make this more readable, either (64 * 1024 * 1024) or (64 << 20)
config.mk is obsolete for this board, and should be removed. (Add
CONFIG_SYS_TEXT_BASE to this header)
Kind regards,
Remy
More information about the U-Boot
mailing list