[U-Boot] [PATCH 0/6] tegra2: Add more clock/pinmux functionality
Simon Glass
sjg at chromium.org
Mon Sep 12 06:37:03 CEST 2011
Hi,
On Thu, Sep 8, 2011 at 3:11 PM, Simon Glass <sjg at chromium.org> wrote:
> This adds to the basic clock functionality already available. The concept
> of a peripheral ID is introduced, and all peripheral clock access is done
> using this ID.
>
[snip]
> Note: These patches include a definition of assert() which I will happily
> remove if the one sent upstream is accepted.
Now that assert() is in master, this needs to be removed. I will send
a new patch set later in the week to tidy this up - just want to allow
a few more days for any comments to come through.
Regards,
Simon
>
>
> Simon Glass (6):
> tegra2: Rename CLOCK_PLL_ID to CLOCK_ID
> tegra2: Clean up board code a little
> tegra2: Add more clock functions
> tegra2: Rename PIN_ to PINGRP_
> tegra2: Add more pinmux functions
> tegra2: Enable MMC for Seaboard
>
> arch/arm/cpu/armv7/tegra2/ap20.c | 5 +-
> arch/arm/cpu/armv7/tegra2/clock.c | 840 +++++++++++++++++++++++++++-
> arch/arm/cpu/armv7/tegra2/pinmux.c | 540 ++++++++++++++++++-
> arch/arm/include/asm/arch-tegra2/clk_rst.h | 84 +--
> arch/arm/include/asm/arch-tegra2/clock.h | 149 ++++-
> arch/arm/include/asm/arch-tegra2/pinmux.h | 444 ++++++++++-----
> board/nvidia/common/board.c | 243 +++------
> board/nvidia/common/board.h | 4 +-
> board/nvidia/harmony/harmony.c | 26 +
> board/nvidia/seaboard/seaboard.c | 35 ++-
> drivers/mmc/tegra2_mmc.c | 94 +--
> drivers/mmc/tegra2_mmc.h | 1 +
> 12 files changed, 1972 insertions(+), 493 deletions(-)
>
> --
> 1.7.3.1
>
>
More information about the U-Boot
mailing list