[U-Boot] [PATCHv1] ARM: Add Altera SOCFPGA Cyclone5
Pavel Machek
pavel at denx.de
Thu Aug 23 12:43:42 CEST 2012
Hi!
> > > diff --git a/Makefile b/Makefile
> > > index 5ce5cc3..12aa372 100644
> > > --- a/Makefile
> > > +++ b/Makefile
> > > @@ -369,7 +369,7 @@ BOARD_SIZE_CHECK =
> > > endif
> > >
> > > # Always append ALL so that arch config.mk's can add custom ones
> > > -ALL-y += $(obj)u-boot.srec $(obj)u-boot.bin $(obj)System.map
> > > +ALL-y += $(obj)u-boot.srec $(obj)u-boot.bin $(obj)u-boot.img
> > > $(obj)System.map
> >
> > This won't slide
>
> You can place this into arch/arm/cpu/armv7/socfpga/config.mk (see
> am33xx/config.mk or any of the others) for examples.
Thanks.
> > > +static unsigned long spl_parse_image_header(const struct image_header
> > > *header) +{
> > > + /* checking for mkimage signature */
> > > + if (__be32_to_cpu(header->ih_magic) == IH_MAGIC) {
> > > + /* Valid image. Extract information out of header */
> > > + spl_image.size = __be32_to_cpu(header->ih_size);
> > > + spl_image.entry_point = __be32_to_cpu(header->ih_load);
> > > + spl_image.load_addr = __be32_to_cpu(header->ih_load);
> > > + spl_image.os = header->ih_os;
> > > + spl_image.name = (const char *)&header->ih_name;
> > > + spl_image.crc = __be32_to_cpu(header->ih_dcrc);
> > > + debug("Subsequent boot image info\n");
> > > + debug(" Image Name: %.*s\n", IH_NMLEN, spl_image.name);
> > > + debug(" Data Size: %d\n", spl_image.size);
> > > + debug(" Load Address: 0x%x\n", spl_image.load_addr);
> > > + debug(" Entry Point: 0x%X\n", spl_image.entry_point);
> > > + } else {
> > > + /* Not a valid image as mkimage signature not found */
> > > + printf("Error : mkimage signature not found - ih_magic = %x\n",
> > > + header->ih_magic);
> > > + return 1;
> > > + }
> > > +
> > > + /* Checking image type. Do any customize stuff per image type here */
> > > + switch (spl_image.os) {
> > > + case IH_OS_U_BOOT:
> > > + debug(" Image Type: U-Boot\n");
> > > + break;
> > > + default:
> > > + printf(" Image Type: Unknown (%d)\n", spl_image.os);
> > > + ;
> > > + }
> > > + return 0;
> > > +}
> >
> > I think I don't even wanna know what's the purpose here :-)
>
> It's the omap-common/spl.c code with the bits for IH_OS_LINUX taken out
> :) Can you please re-do your series on top of the SPL series I just
> posted that provides a common SPL framework? Thanks!
I'll take a look. OTOH, ammount of code duplication here is quite low,
and redoing it on top of SPL series will mean delaying merge, right?
Pavel
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
More information about the U-Boot
mailing list