[U-Boot] [PATCH v3 0/20] Various patches in common/
Simon Glass
sjg at chromium.org
Wed Dec 12 14:47:41 CET 2012
Hi Tom,
On Wed, Dec 12, 2012 at 5:13 AM, Tom Rini <trini at ti.com> wrote:
> On Wed, Dec 05, 2012 at 04:46:27PM -0800, Simon Glass wrote:
>
>> This collection of patches to common/ adds the following:
>>
>> - EDID support for LCD displays
>> - TPM stress test
>> - gettime command to find out the time since boot
>> - Adds coreboot information to the 'version' command
>> - Fixes LMB on x86
>> - SHA256 hashing using a new hashing framework created in response to
>> list feedback
>> - Reading raw data from a partition of a block device
>>
>> Some patches have been dropped from v2 in response to list feedback.
>>
>> Also fixes a few minor bugs and tidy-ups.
>>
>> Changes in v3:
>> - Rename stricmp() to strcasecmp() to match Linux / POSIX
>> - Bracket strcasecmp() declarations with __HAVE_ARCH_...
>> - Rename stricmp() to strcasecmp() to match Linux / POSIX
>> - Correct hash error message to show the algorithm name, not always SHA1
>> - Fix ordering of hash.o in Makefile
>> - Correct hash command help to say 'hash' instead of 'sha1sum'
>> - Drop meminfo from this series
>> - Drop patch 'Update time command to avoid using get_timer_masked()'
>>
>> Changes in v2:
>> - Remove arm: tag from bootstage step patch
>> - Convert space to tab in README
>> - Update gettime commit message to include boards without CONFIG_SYS_HZ
>> - Add more comments to the stdio strncpy commit message
>> - Add new patch to adjust sha1 functions to use const/unsigned
>> - Add new patch to adjust sha256 functions to const and watchdog
>> - Add stricmp() patch again since it is used in this series
>> - Add generic hash API to allow SHA256 command to be added without duplication
>> - Add new patch to change sha1sum to use generic hash API
>> - Add new hash command to support generic hash API
>> - Add patch to enable hashing and EDID on smdk5250
>> - Add x86 patch to enable io command for coreboot
>> - Add x86 tag to version command patch
>>
>> Anton Staaf (1):
>> Add gettime command
>>
>> Kenneth Waters (1):
>> Add a command to read raw blocks from a partition
>>
>> Luigi Semenzato (1):
>> tpm: Add TPM stress test
>>
>> Simon Glass (11):
>> Add new bootstage step for the main loop
>> Fix use of conditional LMB
>> sha1: Use const where possible, and unsigned for input len
>> sha256: Use const where possible and add watchdog function
>> Add strcasecmp() and strncasecmp()
>> Add generic hash API
>> sha1sum: Use generic hash layer
>> Add hash command to perform hashing using various algorithms
>> console: Enable function to display console info
>> exynos: Enable hashing functions and EDID for smdk5250
>> x86: coreboot: Enable io command
>>
>> Stefan Reinauer (1):
>> x86: Add coreboot version to u-boot's version command
>>
>> Tom Wai-Hong Tam (3):
>> edid: Library of EDID decode and print
>> edid: Add I2C command for printing the EDID
>> fdt: edid: Enable fdt_add_edid() function when CONFIG_LCD defined
>>
>> Vadim Bendebury (1):
>> Add console command to access io space registers
>>
>> Vincent Palatin (1):
>> stdio: remove useless strncpy
>>
>> README | 25 +++
>> arch/m68k/include/asm/string.h | 2 +-
>> arch/powerpc/include/asm/string.h | 2 +-
>> arch/sparc/include/asm/string.h | 2 +-
>> common/Makefile | 6 +
>> common/cmd_bootm.c | 2 +-
>> common/cmd_gettime.c | 56 +++++++
>> common/cmd_hash.c | 63 ++++++++
>> common/cmd_i2c.c | 39 +++++
>> common/cmd_io.c | 93 +++++++++++
>> common/cmd_read.c | 81 ++++++++++
>> common/cmd_sha1sum.c | 129 +---------------
>> common/cmd_tpm.c | 93 +++++++++++-
>> common/cmd_version.c | 7 +-
>> common/console.c | 6 +-
>> common/edid.c | 307 +++++++++++++++++++++++++++++++++++++
>> common/fdt_support.c | 2 +-
>> common/hash.c | 221 ++++++++++++++++++++++++++
>> common/main.c | 2 +
>> common/stdio.c | 1 -
>> include/command.h | 8 +-
>> include/config_cmd_all.h | 4 +
>> include/configs/coreboot.h | 1 +
>> include/configs/smdk5250.h | 7 +
>> include/edid.h | 275 +++++++++++++++++++++++++++++++++
>> include/hash.h | 69 +++++++++
>> include/linux/string.h | 7 +-
>> include/sha1.h | 26 +--
>> include/sha256.h | 8 +-
>> lib/sha1.c | 19 ++-
>> lib/sha256.c | 37 +++++-
>> lib/string.c | 16 ++-
>> 32 files changed, 1438 insertions(+), 178 deletions(-)
>> create mode 100644 common/cmd_gettime.c
>> create mode 100644 common/cmd_hash.c
>> create mode 100644 common/cmd_io.c
>> create mode 100644 common/cmd_read.c
>> create mode 100644 common/edid.c
>> create mode 100644 common/hash.c
>> create mode 100644 include/edid.h
>> create mode 100644 include/hash.h
>
> Except for 19 and 20, which never hit patchwork, this is now applied to
> u-boot/master. If you want to put 19 and 20 into u-boot-x86 that's fine
> with me. Thanks!
Thanks. Yes that is odd. I will try resending those two and if that
works, pull into u-boot-x86.
Regards,
Simon
>
> --
> Tom
More information about the U-Boot
mailing list