[U-Boot] [PATCH v2 01/19] Add gpio_request() to asm-generic header

Simon Glass sjg at chromium.org
Wed Jun 13 18:19:37 CEST 2012


This function should also be part of the GPIO API, so add it.

Signed-off-by: Simon Glass <sjg at chromium.org>
---

 include/asm-generic/gpio.h |    9 +++++++++
 1 files changed, 9 insertions(+), 0 deletions(-)

diff --git a/include/asm-generic/gpio.h b/include/asm-generic/gpio.h
index c19e16c..23c9649 100644
--- a/include/asm-generic/gpio.h
+++ b/include/asm-generic/gpio.h
@@ -94,4 +94,13 @@ int gpio_get_value(unsigned gpio);
  */
 int gpio_set_value(unsigned gpio, int value);
 
+/**
+ * Request a gpio. This should be called before any of the other functions
+ * are used on this gpio.
+ *
+ * @param gp	GPIO number
+ * @param label	User label for this GPIO
+ * @return 0 if ok, -1 on error
+ */
+int gpio_request(unsigned gpio, const char *label);
 #endif	/* _ASM_GENERIC_GPIO_H_ */
-- 
1.7.7.3



More information about the U-Boot mailing list