[U-Boot] [PATCH V3 02/32] imximage: remove redundant setting of app_dest_ptr

Troy Kisky troy.kisky at boundarydevices.com
Thu Oct 4 03:47:04 CEST 2012


Signed-off-by: Troy Kisky <troy.kisky at boundarydevices.com>

---
v3: split into its own patch
---
 tools/imximage.c |    1 -
 1 file changed, 1 deletion(-)

diff --git a/tools/imximage.c b/tools/imximage.c
index c917036..bda1a75 100644
--- a/tools/imximage.c
+++ b/tools/imximage.c
@@ -213,7 +213,6 @@ static void set_imx_hdr_v1(struct imx_header *imxhdr, uint32_t dcd_len,
 	/* Set magic number */
 	fhdr_v1->app_code_barker = APP_CODE_BARKER;
 
-	fhdr_v1->app_dest_ptr = params->addr;
 	fhdr_v1->app_dest_ptr = params->ep - imxhdr->flash_offset -
 		sizeof(struct imx_header);
 	fhdr_v1->app_code_jump_vector = params->ep;
-- 
1.7.9.5



More information about the U-Boot mailing list