[U-Boot] [PATCH v2 1/4] mmc: dw-mmc: support DesignWare MMC Controller

Albert ARIBAUD albert.u.boot at aribaud.net
Mon Oct 15 09:01:48 CEST 2012


Hi Jaehoon,

> >> +       desc->des0 = des0;
> >> +       desc->des1 = des1;
> >> +       desc->des2 = des2;
> >> +       desc->des3 = (unsigned int)desc + sizeof(struct dwmci_idmac);
> > 
> > 
> > Also, is there a reason that you've decided to label the 4 fields of
> > your descriptor (which appear to reflect flags, count, address,
> > pointer to next descriptor) as des0-3?
> In DesigneWare IP spec, descriptors are used to those label.

Makes the code pretty cryptic. Better name the struct membder by their
function and comment with their IP spec designations, or maybe name
them by both their IP name and function, e.g. desc->des0_flags,
desc->des1_count etc.

But in any case, local variables (des0, des1...) have zero reason to
be named after the IP spec. These must be renamed according to their
function.

Amicalement,
-- 
Albert.


More information about the U-Boot mailing list