[U-Boot] [PATCH v2 10/11] Add u-boot-ubl.bin target to the Makefile

Tom Rini trini at ti.com
Mon Sep 17 18:51:52 CEST 2012

On 09/17/12 09:27, Scott Wood wrote:
> On 09/17/2012 04:24:34 AM, José Miguel Gonçalves wrote:
>> If no one else has anything against, I will change the name of the new
>> target to u-boot-pad.bin
> What exactly is u-boot-pad.bin supposed to be?  I hope that's not being
> proposed as the final output file the user sees.
> With old nand_spl we had u-boot-nand.bin for the final concatenated
> binary, but that's not appropriate for a generic spl.  I think it would
> be better for the user to see "u-boot.bin" as the actual image to put on
> the boot device, regardless of implementation details like spl, if
> there's no requirement of a specific file format.  The second stage
> could become "u-boot-main.bin" or similar on builds where spl is used.

We need some name that means "U-Boot SPL with U-Boot tacked on at the
end".  This can optionally be padded to a defined size to make writing
to hardware easier.  We also have the problem that "u-boot.bin" already
means something so it needs to be clear.  I further fear that even if we
made an "out" directory if we put u-boot.bin in there and it's not the
same as the objcopy -O binary u-boot u-boot.bin as before we've violated
the rule of least surprise and the end user problems from people that
read "the" document (that happened to be out of date) will be our problem.

In short, at least a few people have said something along the lines of
"We need generic output nameo $mediums and targets" but there's two hard
problems, one of which is that every SoC _needs_ things tweaked just so
(no header? no boot!), sometimes wants things tweaked further (pad the
final image out to be easier to write to $medium) and sometimes needs
multiple files (the whole of 'SPL' will be read so it must fit into
$SMALL_MEMORY).  The other is naming.

I don't want to block this series on this problem.  I do want to say it
needs to use my updated SPL framework or show that it's inadequate (and
I owe another reply to part of this thread still) for this platform.
Call it u-boot.s3c or .s3c24xx and lets continue talking about how to
solve the general problem.


More information about the U-Boot mailing list