[U-Boot] [PATCH v2 17/21] arm: Implement the 'fake' go command

Albert ARIBAUD albert.u.boot at aribaud.net
Tue Jun 11 22:21:52 CEST 2013


Hi Simon,

On Tue, 11 Jun 2013 13:02:56 -0700, Simon Glass <sjg at chromium.org>
wrote:

> Hi Albert,
> 
> On Tue, Jun 11, 2013 at 12:59 PM, Albert ARIBAUD
> <albert.u.boot at aribaud.net>wrote:
> 
> > Hi Simon,
> >
> > On Tue, 11 Jun 2013 11:14:49 -0700, Simon Glass <sjg at chromium.org>
> > wrote:
> >
> > > Implement this feature on ARM for tracing.
> > >
> > > It would be nice to have generic bootm support so that it is easily
> > > implemented on any arch.
> > >
> > > Signed-off-by: Simon Glass <sjg at chromium.org>
> > > ---
> > > Changes in v2: None
> > >
> > >  arch/arm/lib/bootm.c | 33 +++++++++++++++++++++------------
> > >  1 file changed, 21 insertions(+), 12 deletions(-)
> > >
> > > diff --git a/arch/arm/lib/bootm.c b/arch/arm/lib/bootm.c
> > > index 1b6e0ac..28fba19 100644
> > > --- a/arch/arm/lib/bootm.c
> > > +++ b/arch/arm/lib/bootm.c
> >
> > > @@ -225,14 +232,15 @@ static void boot_prep_linux(bootm_headers_t
> > *images)
> > >  }
> > >
> > >  /* Subcommand: GO */
> > > -static void boot_jump_linux(bootm_headers_t *images)
> > > +static void boot_jump_linux(bootm_headers_t *image, int flag)
> >
> > What's the rationale of the s/images/image/ ?
> >
> 
> Just that the function only accesses a single image, so I felt it was a
> misnomer.

I wonder if the naming was not initially chosen to remind readers that
this single image file may actually contain several images
(kernel+initrd, for instance.

> Regards,
> Simon

Amicalement,
-- 
Albert.


More information about the U-Boot mailing list