[U-Boot] [PATCH 6/8] Add TI816X specific register definitions
Peter Korsgaard
jacmet at sunsite.dk
Thu Mar 28 22:37:28 CET 2013
>>>>> "TENART" == TENART Antoine <atenart at adeneo-embedded.com> writes:
TENART> Also move some non common defintions from hardware.h
TENART> ---
TENART> arch/arm/include/asm/arch-am33xx/hardware.h | 7 +--
TENART> arch/arm/include/asm/arch-am33xx/hardware_am33xx.h | 5 ++
TENART> arch/arm/include/asm/arch-am33xx/hardware_ti814x.h | 5 ++
TENART> arch/arm/include/asm/arch-am33xx/hardware_ti816x.h | 58 ++++++++++++++++++++
TENART> 4 files changed, 70 insertions(+), 5 deletions(-)
TENART> create mode 100644 arch/arm/include/asm/arch-am33xx/hardware_ti816x.h
..
TENART> +#define DDRPHY_0_CONFIG_BASE 0x48198000
TENART> +#define DDRPHY_1_CONFIG_BASE 0x4819a000
TENART> +#define DDRPHY_CONFIG_BASE ((emif == 0) ? DDRPHY_0_CONFIG_BASE:DDRPHY_1_CONFIG_BASE)
TENART> +
TENART> +/* CPSW Config space */
TENART> +#define CPSW_MDIO_BASE 0x4A100800
ti816x doesn't have CPSW, so the name is a bit odd (the base address
matches the emac mdio module). The emac driver expects an
asm/arch/emac_defs.h header with a EMAC_MDIO_BASE_ADDR define (among
others).
Perhaps just drop it from here as you're not adding emac support in this
series anyway.
--
Bye, Peter Korsgaard
More information about the U-Boot
mailing list