[U-Boot] [PATCH v2 1/5] usb: ums: code refactoring to improve reusability on other boards.
Marek Vasut
marex at denx.de
Sun Oct 27 19:18:04 CET 2013
Dear Przemyslaw Marczak,
> This patch introduces some cleanups to ums code. Changes:
>
> ums common:
> - introduce UMS_START_SECTOR and UMS_NUM_SECTORS as defined in
> usb_mass_storage.h both default values as 0 if board config
> doesn't define them
>
> common cleanup changes:
> - change name of struct "ums_board_info" to "ums"
> - "ums_device" fields are moved to struct ums and "dev_num" is removed
> - change function name: board_ums_init to ums_init
> - remove "extern" prefixes from usb_mass_storage.h
>
> cmd_usb_mass_storage:
> - change error() to printf() if need to print info message
> - change return values to command_ret_t type at ums command code
> - add command usage string
>
> Changes v2:
> ums common:
> - always returns number of read/write sectors
> - coding style clean-up
> ums gadget:
> - calculate amount of read/write from device returned value.
Hi Lukasz, can I get ack/nak on the series? Thanks!
Best regards,
Marek Vasut
More information about the U-Boot
mailing list