[U-Boot] [PATCH v3] usb: new board-specific USB init interface

Mateusz Zalega m.zalega at samsung.com
Thu Sep 5 19:37:43 CEST 2013


On 09/05/13 17:50, Marek Vasut wrote:
>> v3 changes:
>> - added 'index' argument to perform selective port initialization
> 
> OK, a few general ideas again:
> 
> Why not wrap board_usb_init() and board_usb_init_fail() into single call. You 
> now pass some flags to board_usb_init() already, so just add another for the 
> fail case. How does it sound to you?

Like overengineering. It would lead to "board_usb_init(USB_INIT_ALL,
USB_INIT_DEVICE, USB_CLEANUP)" calls, which are not very readable.

> Moreover, the 'int index' should likely be unsigned int and the special value to 
> init all controllers at once should probably then be 0xffffffff

Despite our greatest ambitions, I don't think we're likely to use more
than 2^31-1 USB controllers at a time. Besides, negative values look
better both in code and debugger session.

Best Regards,

-- 
Mateusz Zalega
Samsung R&D Institute Poland


More information about the U-Boot mailing list