[U-Boot] [PATCH] ARM: tegra: remove custom define for Jetson TK1
Masahiro Yamada
yamada.m at jp.panasonic.com
Fri Aug 1 05:12:37 CEST 2014
Hi Stephen,
On Thu, 31 Jul 2014 17:29:38 -0600
Stephen Warren <swarren at wwwdotorg.org> wrote:
> From: Stephen Warren <swarren at nvidia.com>
>
> Now that Kconfig has a per-board option, we can use that directly rather
> than inventing a custom define for the AS3722 code to determine which
> board it's being built for.
>
> Signed-off-by: Stephen Warren <swarren at nvidia.com>
> ---
> board/nvidia/venice2/as3722_init.h | 2 +-
> configs/jetson-tk1_defconfig | 1 -
> 2 files changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/board/nvidia/venice2/as3722_init.h b/board/nvidia/venice2/as3722_init.h
> index a7b24039f6aa..06c366e0d0d8 100644
> --- a/board/nvidia/venice2/as3722_init.h
> +++ b/board/nvidia/venice2/as3722_init.h
> @@ -18,7 +18,7 @@
> #define AS3722_LDO6VOLTAGE_REG 0x16 /* VDD_SDMMC */
> #define AS3722_LDCONTROL_REG 0x4E
>
> -#ifdef CONFIG_BOARD_JETSON_TK1
> +#ifdef CONFIG_TARGET_JETSON_TK1
> #define AS3722_SD0VOLTAGE_DATA (0x3C00 | AS3722_SD0VOLTAGE_REG)
> #else
> #define AS3722_SD0VOLTAGE_DATA (0x2800 | AS3722_SD0VOLTAGE_REG)
> diff --git a/configs/jetson-tk1_defconfig b/configs/jetson-tk1_defconfig
> index 9ce97c9f61b2..6926257d894b 100644
> --- a/configs/jetson-tk1_defconfig
> +++ b/configs/jetson-tk1_defconfig
> @@ -1,4 +1,3 @@
> CONFIG_SPL=y
> -CONFIG_SYS_EXTRA_OPTIONS="BOARD_JETSON_TK1="
> +S:CONFIG_ARM=y
> +S:CONFIG_TARGET_JETSON_TK1=y
> --
> 1.9.1
Or you may rename CONFIG_TARGET_JETSON_TK1 to CONFIG_BOARD_JETSON_TK1
or another name.
I don't want to force CONFIG_TARGET_ name convention.
You can change config names if you like. It is up to you.
FYI, this is the reason why I used CONFIG_TARGET_ when I
auto-generated the initial version of Kconfig and defconfig files:
The 'integrator' board is supported for various ARM cores such as
arm720t, ar920t, arm926ejs, arm1136. They use the same board
but different config headers.
So CONFIG_BOARD_INTEGRATOR is not an identical macro pointing to
the config header.
When I see Tegra family, each board has its own config header.
CONFIG_BOARD_ as well as CONFIG_TARGET_ will work.
In future, perhaps only the SoC select
(CONFIG_TEGRA20, _TEGRA30, _TEGRA114, _TEGRA124)
will rename in the Kconfig and
the board select might be pushed into device trees.
I am not sure..
Best Regards
Masahiro Yamada
More information about the U-Boot
mailing list