[U-Boot] [PATCH] ARM: tegra: remove custom define for Jetson TK1

Stephen Warren swarren at wwwdotorg.org
Fri Aug 1 20:36:22 CEST 2014


On 07/31/2014 09:12 PM, Masahiro Yamada wrote:
> Hi Stephen,
>
>
>
> On Thu, 31 Jul 2014 17:29:38 -0600
> Stephen Warren <swarren at wwwdotorg.org> wrote:
>
>> From: Stephen Warren <swarren at nvidia.com>
>>
>> Now that Kconfig has a per-board option, we can use that directly rather
>> than inventing a custom define for the AS3722 code to determine which
>> board it's being built for.
>>
>> Signed-off-by: Stephen Warren <swarren at nvidia.com>
>> ---
>>   board/nvidia/venice2/as3722_init.h | 2 +-
>>   configs/jetson-tk1_defconfig       | 1 -
>>   2 files changed, 1 insertion(+), 2 deletions(-)
>>
>> diff --git a/board/nvidia/venice2/as3722_init.h b/board/nvidia/venice2/as3722_init.h
>> index a7b24039f6aa..06c366e0d0d8 100644
>> --- a/board/nvidia/venice2/as3722_init.h
>> +++ b/board/nvidia/venice2/as3722_init.h
>> @@ -18,7 +18,7 @@
>>   #define AS3722_LDO6VOLTAGE_REG	0x16	/* VDD_SDMMC */
>>   #define AS3722_LDCONTROL_REG	0x4E
>>
>> -#ifdef CONFIG_BOARD_JETSON_TK1
>> +#ifdef CONFIG_TARGET_JETSON_TK1
>>   #define AS3722_SD0VOLTAGE_DATA	(0x3C00 | AS3722_SD0VOLTAGE_REG)
>>   #else
>>   #define AS3722_SD0VOLTAGE_DATA	(0x2800 | AS3722_SD0VOLTAGE_REG)
>> diff --git a/configs/jetson-tk1_defconfig b/configs/jetson-tk1_defconfig
>> index 9ce97c9f61b2..6926257d894b 100644
>> --- a/configs/jetson-tk1_defconfig
>> +++ b/configs/jetson-tk1_defconfig
>> @@ -1,4 +1,3 @@
>>   CONFIG_SPL=y
>> -CONFIG_SYS_EXTRA_OPTIONS="BOARD_JETSON_TK1="
>>   +S:CONFIG_ARM=y
>>   +S:CONFIG_TARGET_JETSON_TK1=y
>> --
>> 1.9.1
>
>
>
> Or you may rename CONFIG_TARGET_JETSON_TK1  to CONFIG_BOARD_JETSON_TK1
> or another name.
>
> I don't want to force CONFIG_TARGET_  name convention.
> You can change config names if you like. It is up to you.

I assume you don't object to the current patch, but were just pointing 
out that I could rename the variable if I wanted?

All the configs/${board}_defconfig I looked at use 
CONFIG_TARGET_${board}, so I think it's best if I just convert the code 
to using that so everything is consistent.

...
> When I see Tegra family, each board has its own config header.
> CONFIG_BOARD_ as well as CONFIG_TARGET_ will work.

AFAIK, only Jetson TK1 used a custom CONFIG_BOARD_xxx variable. I only 
did that because it shares some code with Venice2 and needed to define 
some variable do distinguish the two boards, and there wasn't already a 
standard variable for this in the build process. I'm quite happy to 
convert to the standard (or even de-facto) standard variable we have now.


More information about the U-Boot mailing list