[U-Boot] [PATCH v2 5/8] cmd_mmc.c: Rename 'bootpart' to 'bootpart-resize'
Jaehoon Chung
jh80.chung at samsung.com
Tue Feb 4 01:55:00 CET 2014
Acked-by: Jaehoon Chung <jh80.chung at samsung.com>
On 01/31/2014 06:31 AM, Tom Rini wrote:
> Rename 'bootpart' to 'bootpart-resize' to better reflect what this
> command is for.
>
> Signed-off-by: Tom Rini <trini at ti.com>
> ---
> common/cmd_mmc.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/common/cmd_mmc.c b/common/cmd_mmc.c
> index e118252..a322063 100644
> --- a/common/cmd_mmc.c
> +++ b/common/cmd_mmc.c
> @@ -312,9 +312,9 @@ static int do_mmcops(cmd_tbl_t *cmdtp, int flag, int argc, char * const argv[])
> /* acknowledge to be sent during boot operation */
> return boot_part_access(mmc, 1, part_num, access);
>
> - } else if (strcmp(argv[1], "bootpart") == 0) {
> + } else if (strcmp(argv[1], "bootpart-resize") == 0) {
> int dev;
> - struct *mmc;
> + struct mmc *mmc;
> u32 bootsize, rpmbsize;
>
> if (argc == 5) {
> @@ -449,8 +449,8 @@ U_BOOT_CMD(
> " - Enable boot_part for booting and enable R/W access of boot_part\n"
> "mmc close <dev> <boot_partition>\n"
> " - Enable boot_part for booting and disable access to boot_part\n"
> - "mmc bootpart <device num> <boot part size MB> <RPMB part size MB>\n"
> - " - change sizes of boot and RPMB partitions of specified device\n"
> + "mmc bootpart-resize <dev> <boot part size MB> <RPMB part size MB>\n"
> + " - Change sizes of boot and RPMB partitions of specified device\n"
> #endif
> "mmc setdsr - set DSR register value\n"
> );
>
More information about the U-Boot
mailing list