[U-Boot] Pull request: u-boot-spi/next

Jagan Teki jteki at openedev.com
Wed Dec 30 11:34:23 CET 2015


Tom,

Please note that subject shows u-boot-spi/next but it actually
u-boot-spi/master and of course PR shows the repo as master (not
next).

On 30 December 2015 at 16:01, Jagan Teki <jteki at openedev.com> wrote:
> Hi Tom,
>
> Please pull this PR.
>
> thanks!
> Jagan.
>
> The following changes since commit 312db9f75f50b339310474d72c8524cef2bd7931:
>
>   armv7: omap-common: Rework SPL board_mmc_init() (2015-12-14 13:42:54 -0500)
>
> are available in the git repository at:
>
>   git://git.denx.de/u-boot-spi.git master
>
> for you to fetch changes up to 25aade812e40f2e869575199c64e35ebcdf5554b:
>
>   defconfig: am437x_sk_evm: enable spi driver model (2015-12-29 13:27:46 +0530)
>
> ----------------------------------------------------------------
> Jagan Teki (24):
>       sf: Get spi locally from spi_flash
>       spi: make mode visible to both dm and non-dm
>       spi: Use mode instead of op_mode_tx
>       spi: Rename SPI_TX_BP|QPP to SPI_TX_BYTE|QUAD
>       sf: Move spi_read_cmds_array locally
>       sf: Rename spi_flash_set_* functions
>       sf: Rename bank_end to bar_end in read_bar
>       sf: Remove spi_flash_remove
>       sf: Minor cleanup
>       sf: Use BIT macro
>       sf: Fix quad bit set for micron devices
>       sf: Read back and check once spansion quad bit set
>       sf: Read back and check once macronix quad bit set
>       sf: Write quad bit along with read status
>       spi: Remove SPI_OPM_RX_EXTN
>       spi: Remove SPI_OPM_RX_DIO|QIOF
>       spi: Rename SPI_OPM_RX_* to SPI_RX_*
>       spi: Rename op_mode_rx to mode_rx
>       spi: Move flags macro's to spi_slave{} members
>       spi: Fix bit assignment with flags
>       spi: Use BIT macro
>       spi: Minor cleanup
>       sf: Make IO modes at last in read modes
>       spi: Add SPI_TX_DUAL mode
>
> Mugunthan V N (17):
>       drivers: spi: ti_qspi: do not hard code chip select for memory map configuration
>       drivers: spi:ti_qspi: change ti_qspi_slave to ti_qspi_priv for driver model conversion
>       drivers: spi: ti_qspi: prepare driver for DM conversion
>       dm: core: Add a new api to get indexed device address
>       spi: Add support for dual and quad mode
>       dra7xx_evm: qspi: do not define DM_SPI and DM_SPI_FLASH for spl
>       dts: dra7: add spi alias for qspi
>       drivers: spi: ti_qspi: convert driver to adopt device driver model
>       arm: dts: dra7: add qspi register maps for memory map and control module
>       arm: dts: am437x-gp-evm: add spi-flash comaptible for flash
>       arm: dts: dra7-evm: add spi-flash comaptible for flash
>       arm: dts: dra72-evm: add spi-flash comaptible for flash
>       defconfig: dra72_evm: enable spi driver model
>       defconfig: dra74_evm: enable spi driver model
>       am43xx_evm: qspi: do not define DM_SPI and DM_SPI_FLASH for spl
>       arm: dts: am4372: add qspi register maps for memory map
>       defconfig: am437x_sk_evm: enable spi driver model
>
>  arch/arm/dts/am4372.dtsi        |   5 +-
>  arch/arm/dts/am437x-sk-evm.dts  |   2 +-
>  arch/arm/dts/dra7-evm.dts       |   2 +-
>  arch/arm/dts/dra7.dtsi          |   8 +-
>  arch/arm/dts/dra72-evm.dts      |   2 +-
>  configs/am437x_sk_evm_defconfig |   3 +
>  configs/dra72_evm_defconfig     |   2 +
>  configs/dra74_evm_defconfig     |   2 +
>  drivers/core/device.c           |  31 ++-
>  drivers/mtd/spi/sf-uclass.c     |   7 +-
>  drivers/mtd/spi/sf_internal.h   |  55 +++--
>  drivers/mtd/spi/sf_probe.c      |   2 +-
>  drivers/mtd/spi/spi_flash.c     | 185 +++++++++-----
>  drivers/spi/ich.c               |   4 +-
>  drivers/spi/spi-uclass.c        |  38 ++-
>  drivers/spi/ti_qspi.c           | 524 ++++++++++++++++++++++++++++------------
>  include/configs/am43xx_evm.h    |   2 +
>  include/configs/dra7xx_evm.h    |   5 +
>  include/dm/device.h             |  11 +
>  include/spi.h                   |  75 +++---
>  include/spi_flash.h             |   2 -
>  21 files changed, 667 insertions(+), 300 deletions(-)

thanks!
-- 
Jagan.


More information about the U-Boot mailing list