[U-Boot] [PATCH][v2] crypto/fsl: Make function names consistent for blob encapsulation/decapsulation.

York Sun yorksun at freescale.com
Wed Feb 25 00:20:10 CET 2015



On 02/24/2015 02:43 PM, York Sun wrote:
> 
> 
> On 02/20/2015 12:47 AM, Gaurav Rana wrote:
>> This patch does the following:
>>
>> 1. The function names for encapsulation and decapsulation
>> were inconsitent in freescale's implementation and cmd_blob file.
>> This patch corrects the issues.
>> 2. The function protopye is also modified to change the length parameter
>> from u8 to u32 to allow encapsulation and decapsulation of larger images.
>> 3. Modified the description of km paramter in the command usage for better
>> readability.
>>
>> Signed-off-by: Gaurav Rana <gaurav.rana at freescale.com>
>> Reviewed-by: Ruchika Gupta <ruchika.gupta at freescale.com>
>> ---
>> Changes in v2:
>> Modify blob_help_text[] array.
>>
>>  common/cmd_blob.c             | 18 ++++++++++--------
>>  drivers/crypto/fsl/fsl_blob.c |  4 ++--
>>  2 files changed, 12 insertions(+), 10 deletions(-)
>>
>> diff --git a/common/cmd_blob.c b/common/cmd_blob.c
>> index 82ecaf0..6178939 100644
>> --- a/common/cmd_blob.c
>> +++ b/common/cmd_blob.c
>> @@ -90,17 +90,19 @@ static char blob_help_text[] =
>>  	"enc src dst len km - Encapsulate and create blob of data\n"
>>  	"                          $len bytes long at address $src and\n"
>>  	"                          store the result at address $dst.\n"
>> -	"                          $km is the 16 byte key modifier\n"
>> -	"                          is also required for generation/use as\n"
>> -	"                          key for cryptographic operation. Key\n"
>> -	"                          modifier should be 16 byte long.\n"
>> +	"                          $km is the address where the key\n"
>> +	"                          modifier is stored.\n"
>> +	"                          The modifier is required for generation\n"
>> +	"                          /use as key for cryptographic operation.\n"
>> +	"                          Key modifier should be 16 byte long.\n"
>>  	"blob dec src dst len km - Decapsulate the  blob of data at address\n"
>>  	"                          $src and store result of $len byte at\n"
>>  	"                          addr $dst.\n"
>> -	"                          $km is the 16 byte key modifier\n"
>> -	"                          is also required for generation/use as\n"
>> -	"                          key for cryptographic operation. Key\n"
>> -	"                          modifier should be 16 byte long.\n";
>> +	"                          $km is the address where the key\n"
>> +	"                          modifier is stored.\n"
>> +	"                          The modifier is required for generation\n"
>> +	"                          /use as key for cryptographic operation.\n"
>> +	"                          Key modifier should be 16 byte long.\n"
> 
> You removed the semicolon here. Did you see any compiling error?
> 
I think the semicolon should be added back. Otherwise, secure boot boards fail
to compile. I tested on LS1, P4, T2 targets. If you don't have other changes, I
can fix this one.

York



More information about the U-Boot mailing list