[U-Boot] [PATCH v2 6/8] nios2: define _end in link script
Simon Glass
sjg at chromium.org
Fri Sep 4 16:09:41 CEST 2015
Hi Thomas,
On 4 September 2015 at 06:22, Thomas Chou <thomas at wytron.com.tw> wrote:
> Since commit 44c6e6591cb451ae606f8bde71dd5fb7b4002544
> "rename _end to __bss_end__" , the _end was removed.
> But we need it now for separated device tree control,
> ie, CONFIG_OF_SEPARATE .
>
> The _end is used by fdtdec_setup() to find the blob.
>
> Signed-off-by: Thomas Chou <thomas at wytron.com.tw>
> ---
> arch/nios2/cpu/u-boot.lds | 5 +++++
> 1 file changed, 5 insertions(+)
Reviewed-by: Simon Glass <sjg at chromium.org>
>
> diff --git a/arch/nios2/cpu/u-boot.lds b/arch/nios2/cpu/u-boot.lds
> index 951785c..535a974 100644
> --- a/arch/nios2/cpu/u-boot.lds
> +++ b/arch/nios2/cpu/u-boot.lds
> @@ -66,6 +66,11 @@ SECTIONS
> _edata = .;
> PROVIDE (edata = .);
>
> + /* _end - This is end of u-boot.bin image.
comment style:
/*
* _end -
> + * dtb will be appended here to make u-boot-dtb.bin
> + */
> + _end = .;
> +
> /* UNINIT DATA - Small uninitialized data is first so it's
> * adjacent to sdata and can be referenced via gp. The normal
> * bss follows. We keep it adjacent to simplify init code.
> --
> 2.1.4
>
Regards,
Simon
More information about the U-Boot
mailing list