[U-Boot] [PATCH v3 00/27] spi/sf: Updates on flash detection
Jagan Teki
jagannadh.teki at gmail.com
Thu Aug 11 10:15:43 CEST 2016
On 11 August 2016 at 13:36, Jagan Teki <jteki at openedev.com> wrote:
> Updated spi_flash_info table in sync with Linux, and removed
> legacy and unsupported code.
>
> Changes for v3:
> - New patches
> - Fix checkpatch.pl
> - Fix BIT positions in spi.h
> - Fix ti_qspi.c mode
> - Fix commit Nit: s/becuase/because
>
> Changes for v2:
> - New patches.
>
> Jagan Teki (27):
> sf: Simplify fastest read cmd code
> sf: Remove e_rd_cmd from param table
> spi: Use mode for rx mode flags
> spi: Remove SPI_RX_FAST
> sf: Remove SECT_32K
> sf: Add CONFIG_SPI_FLASH_USE_4K_SECTORS in spi_flash
> sf: Move flags macro's to spi_flash_params{} members
> sf: Adopt flash table INFO macro from Linux
> sf: Add JEDEC_ID and JEDEC_EXT macro
> sf: Rename spi_flash_params => spi_flash_info
> sf: Add JEDEC_MFR
> sf: Simplify lock ops detection code
> sf: sandbox: Fix ID exctract from spi_flash_info
> sf: Cleanup spi_flash_info{}
> sf: Cleanup sf_params
> sf: nr_sectors -> n_sectors
> sf: Add SPI_FLASH_MAX_ID_LEN
> sf: Increase max id length by 1 byte
> sf: Add INFO6 flash_info macro
> sf: params: Add S25FS256S_64K spi flash support
> sf: Remove legacy idcode detection code
> sf: Remove non-meaningful comments
> sf: Rename sf_params.c to spi_flash_ids
> sf: ids: Use small letter's with flash name
> sf: ids: Use small letter in ext_jedec
> sf: Rename few local functions
> spi: Remove dual flash code
Tested on microzed and sandbox
Tested-by: Jagan Teki <jteki at openedev.com>
I've some host issues while running buildman, can anyone please run buildman?
thanks!
--
Jagan.
More information about the U-Boot
mailing list