[U-Boot] [PATCH 01/30] dm: Drop the block_dev_desc_t typedef
Bin Meng
bmeng.cn at gmail.com
Tue Feb 16 11:09:27 CET 2016
On Mon, Feb 15, 2016 at 10:16 AM, Simon Glass <sjg at chromium.org> wrote:
> Use 'struct' instead of a typdef. Also since 'struct block_dev_desc' is long
> and causes 80-column violations, rename it to struct blk_desc.
>
> Signed-off-by: Simon Glass <sjg at chromium.org>
> ---
>
> api/api.c | 2 +-
> api/api_storage.c | 14 ++---
> board/cm5200/fwupdate.c | 2 +-
> board/mpl/pip405/README | 4 +-
> cmd/disk.c | 2 +-
> cmd/fat.c | 4 +-
> cmd/gpt.c | 8 +--
> cmd/host.c | 4 +-
> cmd/ide.c | 22 ++++----
> cmd/mmc.c | 2 +-
> cmd/part.c | 8 +--
> cmd/read.c | 4 +-
> cmd/reiser.c | 4 +-
> cmd/sata.c | 10 ++--
> cmd/scsi.c | 12 ++---
> cmd/unzip.c | 2 +-
> cmd/usb.c | 2 +-
> cmd/usb_mass_storage.c | 6 +--
> cmd/zfs.c | 4 +-
> common/env_fat.c | 4 +-
> common/fb_mmc.c | 12 ++---
> common/spl/spl_ext.c | 6 +--
> common/spl/spl_fat.c | 8 +--
> common/spl/spl_sata.c | 2 +-
> common/spl/spl_usb.c | 2 +-
> common/usb_storage.c | 22 ++++----
> disk/part.c | 28 +++++-----
> disk/part_amiga.c | 14 ++---
> disk/part_dos.c | 19 +++----
> disk/part_efi.c | 38 ++++++-------
> disk/part_iso.c | 10 ++--
> disk/part_mac.c | 19 ++++---
> drivers/block/dwc_ahsata.c | 4 +-
> drivers/block/sandbox.c | 12 ++---
> drivers/block/systemace.c | 8 +--
> drivers/dfu/dfu_mmc.c | 2 +-
> drivers/mmc/mmc.c | 4 +-
> drivers/mmc/mmc_private.h | 8 +--
> drivers/mmc/mmc_write.c | 4 +-
> fs/ext4/dev.c | 53 +++++++++---------
> fs/ext4/ext4fs.c | 2 +-
> fs/fat/fat.c | 6 +--
> fs/fs.c | 6 +--
> fs/reiserfs/dev.c | 33 +++++-------
> fs/sandbox/sandboxfs.c | 4 +-
> fs/ubifs/ubifs.c | 2 +-
> fs/zfs/dev.c | 35 ++++++------
> fs/zfs/zfs.c | 2 +-
> include/common.h | 2 +-
> include/ext4fs.h | 6 +--
> include/fat.h | 4 +-
> include/ide.h | 6 +--
> include/mmc.h | 2 +-
> include/part.h | 130 ++++++++++++++++++++++++---------------------
> include/reiserfs.h | 2 +-
> include/sandboxblockdev.h | 2 +-
> include/sandboxfs.h | 2 +-
> include/sata.h | 2 +-
> include/spl.h | 10 ++--
> include/systemace.h | 2 +-
> include/ubifs_uboot.h | 2 +-
> include/usb.h | 2 +-
> include/usb_mass_storage.h | 2 +-
> include/zfs_common.h | 4 +-
> lib/gunzip.c | 2 +-
> test/dm/usb.c | 2 +-
> 66 files changed, 338 insertions(+), 331 deletions(-)
>
Reviewed-by: Bin Meng <bmeng.cn at gmail.com>
More information about the U-Boot
mailing list