[U-Boot] [PATCH v2 00/51] x86: Add support for samus

Bin Meng bmeng.cn at gmail.com
Mon Mar 14 08:09:17 CET 2016


Hi Simon,

On Sat, Mar 12, 2016 at 1:06 PM, Simon Glass <sjg at chromium.org> wrote:
> This series adds support for samus, the Chromebook Pixel 2015. Since it is
> only the second board added that does not use an FSP, there is quite a bit
> of refactoring involved to avoid code duplication.
>
> Samus uses roughly the same binary blobs as link, except now there is one
> more called the reference code binary. The only available binary for this
> is a coreboot 'rmodule' extracted from flash. This is a simplified ELF
> format so it fairly easy to load and use.
>
> It is also possible to boot U-Boot from coreboot on samus. This works well
> but for a delay for non-existent IDE on start-up. The standard build does
> not work with binaries taken from flash, so it isn't easy to replicate
> this - you'll just have to take my word for it. I am working on getting that
> figured out - coreboot recently gained upstream support for loading U-Boot
> as a payload, so it should be possible to get this working nicely before
> long.
>
> In any case much of the code comes from coreboot - individual files are
> credited with their source.
>
> Perhaps the main value of this series is the improved non-FSP support and
> additions for broadwell, which samus uses. It should make it easier to add
> support for future non-FSP platforms.
>
> Changes in v2:
> - Use a #define for the output flush command
> - Adjust the code order slightly
> - Simplify the code in serial_initialize()
> - Use gd->arch.x86_mask to get the stepping value
> - Rename microcode_intel.c to microcode.c
> - Use capitals for header guard
> - Use capitals for header guard
> - Move cougarcanyon lpc_common.h include to this patch
> - Use capitals for header guard
> - Use capitals for header guard
> - Rename sdram_common.c to mrc.c
> - Rename sdram to mrc
> - Use setio_32() instead of setio_le32(), etc.
> - Add Kconfig help for the moved options
> - Fix tab indentation
> - Don't try to read microcode version on quark
> - Use gd->arch.x86_device instead of reading the device ID again
> - Rename subject to 'core' instead of 'code'
> - Fix micrcode typo
> - Don't try to update microcode on FSP platforms
> - Add GPIO output definition for a1 and a6
> - Use setio_32() instead of setio_le32(), etc.
> - Fix 'PCB' typo (should be 'PCH')
> - Use setio_32() instead of setio_le32(), etc.
> - Use capitals for header guard
> - Use capitals for header guard
> - Use capitals for header guard
> - Fix comment style
> - Use capitals for header guard
> - Rename sdram to mrc
> - Use setio_32() instead of setio_le32(), etc.
> - Fix 'configure' typo
> - Correct naming of Intel platforms
>

I've applied most of the series to u-boot-x86/next to make things
easier for the next spin. Please work on the remaining 8 patches.
Thanks!

Regards,
Bin


More information about the U-Boot mailing list