[U-Boot] [PATCH v2 0/7] clk: at91: Improve the clock implementation
Wenyou Yang
wenyou.yang at atmel.com
Sun Sep 18 08:53:07 CEST 2016
Add the clock ops for such as spi0_clk, which is the real clock
provider, instead of periph32ck, which only recursively bind its
children as clk devices. Also update the clocks called in the
drivers.
Changes in v2:
- Add Acked-by tag.
- For the periph32ck, periph64ck, gck, systemck nodes, they aren't
the clock providers, are to house various actual clock providers,
use UCLASS_MISC, instead of UCLASS_CLK.
- For *_of_xlate(), add argument check.
- Fix the implementation of the *_get_rate().
- Use documentation-wise variables for *_clk_probe().
- Remove the duplicated code, use the common functions.
- Add Acked-by tag for gpio/atmel_pio4.
Wenyou Yang (7):
clk: clk-uclass: Assign clk->dev before call .of_xlate
clk: at91: Improve the clock implementation
gpio: atmel_pio4: Remove unneccessary clock calling
i2c: at91_i2c: Remove unneccessary clock calling
i2c: at91_i2c: Change error return -ENODEV to -EINVAL
usb: ehci-atmel: Remove unneccessary clock calling
mmc: atmel_sdhci: Remove unneccessary clock calling
drivers/clk/at91/Kconfig | 1 +
drivers/clk/at91/clk-generated.c | 92 +++++++++++++++++++++++++--------------
drivers/clk/at91/clk-peripheral.c | 83 ++++++++++++++++++++++++++---------
drivers/clk/at91/clk-system.c | 62 +++++++++++++++++---------
drivers/clk/at91/pmc.c | 62 +++++++++++++++++++++++---
drivers/clk/at91/pmc.h | 5 ++-
drivers/clk/clk-uclass.c | 3 ++
drivers/gpio/atmel_pio4.c | 12 -----
drivers/i2c/at91_i2c.c | 18 +-------
drivers/mmc/atmel_sdhci.c | 27 +-----------
drivers/usb/host/ehci-atmel.c | 15 -------
11 files changed, 228 insertions(+), 152 deletions(-)
--
2.7.4
More information about the U-Boot
mailing list