[U-Boot] [PATCH v2 18/40] dm: sata: dw_sata: Rename the dwc_ahsata private header
Simon Glass
sjg at chromium.org
Sat Jul 29 17:35:09 UTC 2017
Rename dwc_ahsata.h to indicate that it is a private header file. We plan
to create another header with some public functions.
Signed-off-by: Simon Glass <sjg at chromium.org>
---
Changes in v2: None
drivers/ata/dwc_ahsata.c | 2 +-
drivers/ata/{dwc_ahsata.h => dwc_ahsata_priv.h} | 6 +++---
2 files changed, 4 insertions(+), 4 deletions(-)
rename drivers/ata/{dwc_ahsata.h => dwc_ahsata_priv.h} (99%)
diff --git a/drivers/ata/dwc_ahsata.c b/drivers/ata/dwc_ahsata.c
index b6915d217b..8056bc94a3 100644
--- a/drivers/ata/dwc_ahsata.c
+++ b/drivers/ata/dwc_ahsata.c
@@ -17,7 +17,7 @@
#include <linux/bitops.h>
#include <linux/ctype.h>
#include <linux/errno.h>
-#include "dwc_ahsata.h"
+#include "dwc_ahsata_priv.h"
struct sata_port_regs {
u32 clb;
diff --git a/drivers/ata/dwc_ahsata.h b/drivers/ata/dwc_ahsata_priv.h
similarity index 99%
rename from drivers/ata/dwc_ahsata.h
rename to drivers/ata/dwc_ahsata_priv.h
index caa2e501f9..6089c0b268 100644
--- a/drivers/ata/dwc_ahsata.h
+++ b/drivers/ata/dwc_ahsata_priv.h
@@ -5,8 +5,8 @@
* SPDX-License-Identifier: GPL-2.0+
*/
-#ifndef __FSL_SATA_H__
-#define __FSL_SATA_H__
+#ifndef __DWC_AHSATA_PRIV_H__
+#define __DWC_AHSATA_PRIV_H__
#define DWC_AHSATA_MAX_CMD_SLOTS 32
@@ -317,4 +317,4 @@
#define READ_CMD 0
#define WRITE_CMD 1
-#endif /* __FSL_SATA_H__ */
+#endif /* __DWC_AHSATA_H__ */
--
2.14.0.rc0.400.g1c36432dff-goog
More information about the U-Boot
mailing list