[U-Boot] [PATCH v3 1/2] imx: add macro to detect whether USB PHY is active
Stefan Agner
stefan at agner.ch
Wed Sep 13 21:28:23 UTC 2017
Sorry, the subject should have been v4.
--
Stefan
On 2017-09-13 14:29, Stefan Agner wrote:
> From: Stefan Agner <stefan.agner at toradex.com>
>
> This macro allows to detect whether the USB PHY is active. This
> is helpful to detect if the boot ROM has previously started the
> USB serial downloader.
>
> The idea is taken from the mfgtool support in the NXP U-Boot:
> http://git.freescale.com/git/cgit.cgi/imx/uboot-imx.git/commit/?h=imx_v2016.03_4.1.15_2.0.0_ga&id=a352ed3c5184b95c4c9f7468f5fbb5f43de5e412
>
> Signed-off-by: Stefan Agner <stefan.agner at toradex.com>
> Acked-by: Marcel Ziswiler <marcel.ziswiler at toradex.com>
> Tested-by: Fabio Estevam <fabio.estevam at nxp.com>
> ---
>
> Changes in v4:
> - Rename macro to is_usbotg_phy_active()
>
> Changes in v3: None
> Changes in v2:
> - Move macro to sys_proto.h
> - Renamed from is_boot_from_usb() to is_usbphy_active()
> - Use defines for register offset and field
> - Remove tab after define
> - Remove comment since the actual "magic" is happening and
> documented at usage side
>
> arch/arm/include/asm/arch-mx6/sys_proto.h | 7 +++++++
> 1 file changed, 7 insertions(+)
>
> diff --git a/arch/arm/include/asm/arch-mx6/sys_proto.h
> b/arch/arm/include/asm/arch-mx6/sys_proto.h
> index 14f5d948c9..ba73943260 100644
> --- a/arch/arm/include/asm/arch-mx6/sys_proto.h
> +++ b/arch/arm/include/asm/arch-mx6/sys_proto.h
> @@ -6,3 +6,10 @@
> */
>
> #include <asm/mach-imx/sys_proto.h>
> +
> +#define USBPHY_PWD 0x00000000
> +
> +#define USBPHY_PWD_RXPWDRX (1 << 20) /* receiver block power down */
> +
> +#define is_usbotg_phy_active(void) (!(readl(USB_PHY0_BASE_ADDR +
> USBPHY_PWD) & \
> + USBPHY_PWD_RXPWDRX))
On 2017-09-13 14:29, Stefan Agner wrote:
> From: Stefan Agner <stefan.agner at toradex.com>
>
> This macro allows to detect whether the USB PHY is active. This
> is helpful to detect if the boot ROM has previously started the
> USB serial downloader.
>
> The idea is taken from the mfgtool support in the NXP U-Boot:
> http://git.freescale.com/git/cgit.cgi/imx/uboot-imx.git/commit/?h=imx_v2016.03_4.1.15_2.0.0_ga&id=a352ed3c5184b95c4c9f7468f5fbb5f43de5e412
>
> Signed-off-by: Stefan Agner <stefan.agner at toradex.com>
> Acked-by: Marcel Ziswiler <marcel.ziswiler at toradex.com>
> Tested-by: Fabio Estevam <fabio.estevam at nxp.com>
> ---
>
> Changes in v4:
> - Rename macro to is_usbotg_phy_active()
>
> Changes in v3: None
> Changes in v2:
> - Move macro to sys_proto.h
> - Renamed from is_boot_from_usb() to is_usbphy_active()
> - Use defines for register offset and field
> - Remove tab after define
> - Remove comment since the actual "magic" is happening and
> documented at usage side
>
> arch/arm/include/asm/arch-mx6/sys_proto.h | 7 +++++++
> 1 file changed, 7 insertions(+)
>
> diff --git a/arch/arm/include/asm/arch-mx6/sys_proto.h
> b/arch/arm/include/asm/arch-mx6/sys_proto.h
> index 14f5d948c9..ba73943260 100644
> --- a/arch/arm/include/asm/arch-mx6/sys_proto.h
> +++ b/arch/arm/include/asm/arch-mx6/sys_proto.h
> @@ -6,3 +6,10 @@
> */
>
> #include <asm/mach-imx/sys_proto.h>
> +
> +#define USBPHY_PWD 0x00000000
> +
> +#define USBPHY_PWD_RXPWDRX (1 << 20) /* receiver block power down */
> +
> +#define is_usbotg_phy_active(void) (!(readl(USB_PHY0_BASE_ADDR +
> USBPHY_PWD) & \
> + USBPHY_PWD_RXPWDRX))
More information about the U-Boot
mailing list