[U-Boot] [PATCH v3 13/13] misc: Add IHS FPGA driver

Mario Six mario.six at gdsys.cc
Fri Aug 3 07:32:57 UTC 2018


Hi Simon,

On Thu, Aug 2, 2018 at 6:56 PM, Simon Glass <sjg at chromium.org> wrote:
> On 31 July 2018 at 04:01, Mario Six <mario.six at gdsys.cc> wrote:
>> Add a driver for gdsys IHS (Integrated Hardware Systems) FPGAs, which
>> supports initialization of the FPGA, as well as information gathering.
>>
>> Signed-off-by: Mario Six <mario.six at gdsys.cc>
>> ---
>>
>> v2 -> v3:
>> * Fixed style violations
>> * Added full documentation
>> * Extracted some magic numbers to constants
>> * Removed unnecessary includes
>> * Extracted wait_for_fpga_done
>> * Improved error handling and reporting
>> * Added device-tree-binding files
>> * Improved Kconfig entry
>>
>> v1 -> v2:
>> New in v2
>>
>> ---
>>  .../devicetree/bindings/misc/gdsys,iocon_fpga.txt  |  19 +
>>  .../devicetree/bindings/misc/gdsys,iocpu_fpga.txt  |  19 +
>>  drivers/misc/Kconfig                               |   9 +
>>  drivers/misc/Makefile                              |   1 +
>>  drivers/misc/ihs_fpga.c                            | 867 +++++++++++++++++++++
>>  drivers/misc/ihs_fpga.h                            |  49 ++
>>  6 files changed, 964 insertions(+)
>>  create mode 100644 Documentation/devicetree/bindings/misc/gdsys,iocon_fpga.txt
>>  create mode 100644 Documentation/devicetree/bindings/misc/gdsys,iocpu_fpga.txt
>>  create mode 100644 drivers/misc/ihs_fpga.c
>>  create mode 100644 drivers/misc/ihs_fpga.h
>
> Reviewed-by: Simon Glass <sjg at chromium.org>
>
> My only nit is that I prefer 'ret' for the return value instead of
> 'rc' or 'res', for consistency with driver model.

Eh, I'll do a v4 anyway, so I can fix this as well, no problem.

I wasn't aware that there was a preference in naming convention regarding
return variables, but your explanation definitely makes sense. That's another
one of these little tidbits that should probably be documented somewhere.

Best regards,
Mario


More information about the U-Boot mailing list