[U-Boot] [PATCH v2 0/5] Add get_alternate_function ops
Simon Glass
sjg at chromium.org
Wed Aug 8 09:55:11 UTC 2018
Hi Patrice,
On 3 August 2018 at 09:01, Patrice Chotard <patrice.chotard at st.com> wrote:
>
> This series :
> - Add new gpio ops get_alternate_function
> - Add get_function and get_alternate_function support to stm32 gpio driver
> - Add get_alternate_function test
>
> Changes in v2:
> - Rename get_function_number to get_alternate_function
> in include/asm-generic/gpio.h
> - Rename get_function_number to get_alternate_function in
> drivers/gpio/stm32f7_gpio.c
> - Rename get_function_number to get_alternate_function
> in test/dm/gpio.c, drivers/gpio/sandbox.c and in
> arch/sandbox/include/asm/gpio.h
>
> Christophe Kerello (1):
> gpio: stm32f7: Add ops get_function
>
> Patrice Chotard (2):
> gpio: sandbox: Rename GPIOF_(OUTPUT|HIGH|ODR) to
> SDBX_GPIO_(OUTPUT|HIGH|ODR)
> test: dm: Add gpio get_alternate_function ops test
>
> Patrick Delaunay (2):
> dm: gpio: Add get_alternate_function ops
> gpio: stm32f7: Add ops get_alternate_function
>
> arch/sandbox/include/asm/gpio.h | 24 ++++++++++++++++++++
> drivers/gpio/gpio-uclass.c | 6 +++++
> drivers/gpio/sandbox.c | 49 ++++++++++++++++++++++++++++++++---------
> drivers/gpio/stm32f7_gpio.c | 36 ++++++++++++++++++++++++++++++
> include/asm-generic/gpio.h | 13 +++++++++++
> test/dm/gpio.c | 13 +++++++++++
> 6 files changed, 130 insertions(+), 11 deletions(-)
>
This series looks OK, but I am wondering how it fits with pinctrl.
(e.g. get_gpio_mux)?
Regards,
Simon
More information about the U-Boot
mailing list