[U-Boot] [PATCH 2/2] Convert CONFIG_SYS_BOOTCOUNT_SINGLEWORD to Kconfig

Alex Kiernan alex.kiernan at gmail.com
Sun Feb 11 19:23:56 UTC 2018


On Fri, Feb 9, 2018 at 10:53 PM, Lukasz Majewski <lukma at denx.de> wrote:
> This converts the following to Kconfig:
>    CONFIG_SYS_BOOTCOUNT_SINGLEWORD
>
> Signed-off-by: Lukasz Majewski <lukma at denx.de>
> ---
>
>  configs/highbank_defconfig | 1 +
>  drivers/bootcount/Kconfig  | 6 ++++++
>  include/configs/highbank.h | 1 -
>  3 files changed, 7 insertions(+), 1 deletion(-)
>
> diff --git a/configs/highbank_defconfig b/configs/highbank_defconfig
> index 41f4ef5f78..60a43db197 100644
> --- a/configs/highbank_defconfig
> +++ b/configs/highbank_defconfig
> @@ -25,6 +25,7 @@ CONFIG_EFI_PARTITION=y
>  CONFIG_ENV_IS_IN_NVRAM=y
>  CONFIG_SCSI_AHCI=y
>  CONFIG_BOOTCOUNT_LIMIT=y
> +CONFIG_SYS_BOOTCOUNT_SINGLEWORD=y
>  # CONFIG_MMC is not set
>  CONFIG_SCSI=y
>  CONFIG_OF_LIBFDT=y
> diff --git a/drivers/bootcount/Kconfig b/drivers/bootcount/Kconfig
> index cb6be73d52..d82289f57b 100644
> --- a/drivers/bootcount/Kconfig
> +++ b/drivers/bootcount/Kconfig
> @@ -17,6 +17,12 @@ config BOOTCOUNT_LIMIT
>           Enable checking for exceeding the boot count limit.
>           More information: http://www.denx.de/wiki/DULG/UBootBootCountLimit
>
> +config SYS_BOOTCOUNT_SINGLEWORD
> +       bool "Use single word to pack boot count and magic value"
> +       help
> +         This option enables packing boot count magic value and boot count
> +         into single word (32 bits).
> +
>  if BOOTCOUNT
>
>  config BOOTCOUNT_EXT
> diff --git a/include/configs/highbank.h b/include/configs/highbank.h
> index 2831aa3875..6c5d3ae3ac 100644
> --- a/include/configs/highbank.h
> +++ b/include/configs/highbank.h
> @@ -26,7 +26,6 @@
>  #define CONFIG_PL01x_PORTS             { (void *)(0xFFF36000) }
>  #define CONFIG_CONS_INDEX              0
>
> -#define CONFIG_SYS_BOOTCOUNT_SINGLEWORD
>  #define CONFIG_SYS_BOOTCOUNT_LE                /* Use little-endian accessors */
>  #define CONFIG_SYS_BOOTCOUNT_ADDR      0xfff3cf0c
>

Tested-by: Alex Kiernan <alex.kiernan at gmail.com>

-- 
Alex Kiernan


More information about the U-Boot mailing list