[U-Boot] [PATCH v4 00/11] arm: sunxi: Use proper and meaningful Kconfig entries
Jagan Teki
jagan at amarulasolutions.com
Fri Mar 16 09:04:25 UTC 2018
Current arch/arm/mach-sunxi/Makefile has improper build options
which relies mostly on MACH_ options. This series get rid of those
and added proper Kconfig options.
All Kconfig entry name are re-used from Linux so-that future
dm conversion on these can be meaningful.
Changes for v4:
- Rename MFD_SUN6I_PRCM to SUN6I_PRCM
- Rename PMIC_AXP to AXP_PMIC_BUS
- Collect Acked-by from Maxime
Changes for v3:
- Rename SUNXI_RSB to SUN8I_RSB
- Drop or invisible few generic config bool strings
Changes for v2:
- Renamed PMIC_SUNXI to PMIC_AXP, so it PMIC driver implies to have AXP helpers
and name start with PMIC_ sothat the notation can compatible with pmic dm-drivers
Jagan Teki (11):
sunxi: Add SUN6I_PRCM kconfig entry
sunxi: Add I2C_SUN6I_P2WI kconfig entry
sunxi: Use SUN6I_PRCM if used
sunxi: Add SUN8I_RSB kconfig entry
sunxi: Add AXP_PMIC_BUS kconfig entry
sunxi: add DRAM_SUN6I kconfig
sunxi: Add DRAM_SUN4I kconfig entry
sunxi: Add DRAM_SUN9I kconfig entry
sunxi: Add DRAM_SUN8I_A23 kconfig entry
sunxi: Add DRAM_SUN8I_A33 kconfig entry
sunxi: Add DRAM_SUN8I_A83T kconfig entry
arch/arm/mach-sunxi/Kconfig | 81 ++++++++++++++++++++++++++++++++++++++++++++
arch/arm/mach-sunxi/Makefile | 30 ++++++----------
drivers/power/Kconfig | 5 +++
3 files changed, 96 insertions(+), 20 deletions(-)
--
2.14.3
More information about the U-Boot
mailing list