[U-Boot] [PATCH v2 0/2] efi_loader: adjust definitions of variable services
Heinrich Schuchardt
xypron.glpk at gmx.de
Thu May 17 05:57:04 UTC 2018
The definitons of the variable services are adjusted:
- use efi_uintn_t instead of unsigned long
- use u16 * instead of s16 * for Unicode strings
- correct definition of QueryVariableInfo
- rename efi_get_next_variable to efi_get_next_variable_name
A unit test for the variable services is supplied.
v2:
fix warning when building on 64bit architecture
Heinrich Schuchardt (2):
efi_loader: adjust definitions of variable services
efi_selftest: unit test for variable services
include/efi_api.h | 24 +--
include/efi_loader.h | 18 +--
lib/efi_loader/efi_bootmgr.c | 10 +-
lib/efi_loader/efi_runtime.c | 10 +-
lib/efi_loader/efi_variable.c | 24 +--
lib/efi_selftest/Makefile | 1 +
lib/efi_selftest/efi_selftest_variables.c | 180 ++++++++++++++++++++++
7 files changed, 224 insertions(+), 43 deletions(-)
create mode 100644 lib/efi_selftest/efi_selftest_variables.c
--
2.17.0
More information about the U-Boot
mailing list