[U-Boot] [PATCH v2 3/8] cmd: bootimg: Add bootimg command

Eugeniu Rosca erosca at de.adit-jv.com
Wed Dec 4 18:33:49 CET 2019


Hello Sam,
Please, see one more suggestion below.

On Tue, Dec 03, 2019 at 08:29:10PM +0100, Eugeniu Rosca wrote:
> Hi Sam,
> Cc: Aleksandr, Roman
> 
> As expressed in the attached e-mail, to minimize the headaches extending
> the argument list of "bootimg" in future, can we please agree on below?
> 
> On Wed, Oct 23, 2019 at 05:34:22PM +0300, Sam Protsenko wrote:
> > +U_BOOT_CMD(
> > +	bootimg, CONFIG_SYS_MAXARGS, 0, do_bootimg,
> > +	"manipulate Android Boot Image",
> > +	"set_addr <addr>\n"
> > +	"    - set the address in RAM where boot image is located\n"
> > +	"      ($loadaddr is used by default)\n"
> > +	"bootimg ver <varname>\n"
> 
> Can we make <varname> optional, with the background provided in [1]?
> 
> > +	"    - get header version\n"
> > +	"bootimg get_dtbo <addr_var> [size_var]\n"
> 
> How about converting <addr_var> to an optional argument too?
> 
> > +	"    - get address and size (hex) of recovery DTBO area in the image\n"
> > +	"      <addr_var>: variable name to contain DTBO area address\n"
> > +	"      [size_var]: variable name to contain DTBO area size\n"
> > +	"bootimg dtb_dump\n"
> > +	"    - print info for all files in DTB area\n"
> > +	"bootimg dtb_load_addr <varname>\n"
> 
> Same as above w.r.t. <varname>.
> 
> > +	"    - get load address (hex) of DTB\n"
> > +	"bootimg get_dtb_file <index> <addr_var> [size_var]\n"

How about "get_dte" or "get_dtbe" instead of "get_dtb_file" ?
It's shorter and should be easier to remember (dt{b}e = DT{B} Entry).

-- 
Best Regards,
Eugeniu


More information about the U-Boot mailing list