[PATCH 0/3] cmd: dtimg: Rename to adtimg and refactor usage style
Eugeniu Rosca
roscaeugeniu at gmail.com
Tue Dec 24 17:51:05 CET 2019
The main focus of this series is to prepare the ground for:
- adding the id/rev-based DT lookup in dtimg/adtimg [1]
- adding the abootimg command [2]
To be more clear, the above topics are handled _outside_ of this series,
but they treat this series as hard dependency.
The per-patch motivation and testing are described meticulously
in each commit.
[1] https://patchwork.ozlabs.org/patch/1202580/
("cmd: dtimg: Get start and size based on --id and --rev")
[2] https://patchwork.ozlabs.org/patch/1182212/
("cmd: bootimg: Add bootimg command")
Eugeniu Rosca (3):
dtimg/am57xx_evm_defconfig: Rename dtimg to adtimg
cmd: adtimg: Rename internal symbols
cmd: adtimg: Refactor usage style
cmd/Kconfig | 4 +-
cmd/Makefile | 2 +-
cmd/adtimg.c | 242 ++++++++++++++++++++++++++++
cmd/dtimg.c | 142 ----------------
common/Makefile | 2 +-
configs/am57xx_evm_defconfig | 2 +-
configs/am57xx_hs_evm_defconfig | 2 +-
configs/am57xx_hs_evm_usb_defconfig | 2 +-
8 files changed, 249 insertions(+), 149 deletions(-)
create mode 100644 cmd/adtimg.c
delete mode 100644 cmd/dtimg.c
--
2.24.0
More information about the U-Boot
mailing list