[U-Boot] [PATCH v5 3/8] x86: slimbootloader: Add memory configuration
Park, Aiden
aiden.park at intel.com
Wed Jul 24 02:53:52 UTC 2019
Hi Andy,
> -----Original Message-----
> From: Andy Shevchenko [mailto:andy.shevchenko at gmail.com]
> Sent: Monday, July 22, 2019 8:34 AM
> To: Park, Aiden <aiden.park at intel.com>
> Cc: U-Boot Mailing List <u-boot at lists.denx.de>; Simon Glass
> <sjg at chromium.org>; Bin Meng <bmeng.cn at gmail.com>
> Subject: Re: [PATCH v5 3/8] x86: slimbootloader: Add memory configuration
>
> On Wed, Jul 17, 2019 at 7:41 AM Park, Aiden <aiden.park at intel.com> wrote:
> >
> > Slim Bootloader provides memory map info thru its HOB list pointer.
> > Configure memory size and relocation memory from the HOB data, and
> > provide e820 entries as well.
> > - Get memory size from the memory map info hob
> > - Set ram top for U-Boot relocation lower than 4GB
> > - Provide e820 entries from the memory map info hob
>
> > +++ b/arch/x86/cpu/slimbootloader/dram.c
>
> sdram.c is more common name in the sources AFAICS.
>
Okay. let me use sdram.
> > +ulong board_get_usable_ram_top(ulong total_size) {
> > + struct memory_map_info *data = NULL;
> > + int i = 0;
> > + phys_addr_t addr_start = 0;
> > + phys_addr_t addr_end = 0;
>
> Unnecessary assignments (check entire series for them).
>
Okay. let me check this in entire series.
> > + data = (struct memory_map_info *)get_memory_map_info();
>
> Casting from / to void * is redundant. Check entire series.
>
Do you mean casting void * to (struct *)? Anyway, let me remove casting if redundant in entire series.
> > + if (!data)
> > + panic("memory map info hob not found\n");
>
> > + /**
> > + * sorted memory map entries from Slim Bootloader based on physical
> > + * start memory address, from low to high. So do reversed search to
> > + * get highest usable, suitable size, 4KB aligned available memory
> > + * under 4GB.
> > + */
>
> > + for (i = data->count - 1; i >= 0; i--) {
>
> Hmm... Maybe
>
> i = data->count;
> while (i--) {
> ...
> }
>
> Easier to read.
>
Okay. let me change this.
> > + if (data->entry[i].type != E820_RAM)
> > + continue;
> > +
> > + addr_start = data->entry[i].addr;
> > + addr_end = addr_start + data->entry[i].size;
> > +
> > + if (addr_start > SZ_4G)
> > + continue;
> > +
> > + if (addr_end > SZ_4G)
> > + addr_end = SZ_4G;
> > +
> > + if (addr_end < total_size)
> > + continue;
> > +
>
> > + /* to relocate u-boot at 4K aligned memory */
>
> u-boot -> U-Boot
>
Let me change this.
> > + addr_end = rounddown(addr_end - total_size, SZ_4K);
> > + if (addr_end >= addr_start) {
> > + ram_top = (ulong)addr_end + total_size;
> > + break;
> > + }
> > + }
> > +
> > + if (!ram_top)
> > + panic("failed to find available memory for
> > + relocation!");
> > +
> > + return ram_top;
> > +}
> > +
> > +/**
> > + * The memory initialization has already been done in previous Slim
> > +Bootloader
> > + * stage thru FSP-M. Instead, this sets the ram_size from the memory
> > +map info
> > + * hob.
> > + */
> > +int dram_init(void)
> > +{
> > + struct memory_map_info *data = NULL;
> > + int i = 0;
> > + phys_size_t ram_size = 0;
> > +
> > + data = (struct memory_map_info *)get_memory_map_info();
> > + if (!data)
> > + panic("memory map info hob not found\n");
> > +
> > + /**
> > + * sorted memory map entries from Slim Bootloader based on physical
> > + * start memory address, from low to high. So do reversed search to
> > + * simply get highest usable memory address as ram size
> > + */
>
> > + for (i = data->count - 1; i >= 0; i--) {
> > + if (data->entry[i].type != E820_RAM)
> > + continue;
>
> Second time?
>
> Perhaps you may do rather macro:
>
> #define for_each_map_info_entry_reversed(...) \
> for () \
> if (!cond) {} else
>
Okay, let me use macro.
> > +
> > + /* simply use the highest usable memory address as ram
> > + size */
>
> ram -> RAM
>
Let me change this.
> > + ram_size = data->entry[i].addr + data->entry[i].size;
> > + break;
> > + }
> > +
> > + if (!ram_size)
> > + panic("failed to detect memory size");
> > +
> > + gd->ram_size = ram_size;
> > + return 0;
> > +}
>
> > +int dram_init_banksize(void)
> > +{
> > + /* simply use a single bank to have whole size for now */
> > + if (CONFIG_NR_DRAM_BANKS) {
>
> if (!foo) might be slightly better if ever this code gets modified.
>
Okay. Let me change this.
> > + gd->bd->bi_dram[0].start = 0;
> > + gd->bd->bi_dram[0].size = gd->ram_size;
> > + }
> > + return 0;
> > +}
>
> > +#define LOADER_MEMORY_MAP_INFO_GUID \
> > + { \
> > + 0xa1ff7424, 0x7a1a, 0x478e, \
> > + { 0xa9, 0xe4, 0x92, 0xf3, 0x57, 0xd1, 0x28, 0x32 } \
> > + }
>
> EFI_GUID() ?
>
Okay, let me use EFI_GUID.
> > +/**
> > + * A single entry of memory map information
> > + *
> > + * @addr: start address of a memory map entry
> > + * @size: size of a memory map entry
> > + * @type: usable:1, reserved:2, acpi:3, nvs:4, unusable:5
> > + * @flag: only used in Slim Bootloader
> > + * @rsvd: padding for alignment
> > + */
> > +struct memory_map_entry {
>
> > + phys_addr_t addr;
> > + phys_size_t size;
>
> This is comes from hardware, isn't it? Probably better to use fixed width typo
>
Okay, let me use u64 for address and size.
> > + u8 type;
> > + u8 flag;
> > + u8 rsvd[6];
> > +} __packed;
>
> --
> With Best Regards,
> Andy Shevchenko
Best Regards,
Aiden
More information about the U-Boot
mailing list