[U-Boot] [PATCH] sifive: riscv: update Hifive Unleashed configuration infrastructure
Sagar Kadam
sagar.kadam at sifive.com
Tue Jul 30 17:10:12 UTC 2019
Hello Bin,
On Mon, Jul 29, 2019 at 7:15 PM Bin Meng <bmeng.cn at gmail.com> wrote:
>
> Hi,
>
> On Mon, Jul 29, 2019 at 8:42 PM Sagar Shrikant Kadam
> <sagar.kadam at sifive.com> wrote:
> >
> > This patch aligns the current implementation of HiFive Unleashed
> > board configuration framework with the one described in doc/README.kconfig.
> >
>
> Can you please explain why these changes are needed? It looks that the
> changes are only to rename the "generic" cpu name to "u54-mc", and
> rename the board name "fu540" to "hifive_unleashed"?
>
This patch is intended to update the naming convention which U-boot mentions in
doc/README.kconfig. As we know that FU540-C000 has a U54-MC CPU core, I thought
of naming it as u54-mc and board name from fu540 to hifive_unleashed
which is the
actual case.
> This breaks the QEMU virt boards.
>
Unfortunately yes. Hence I raised a request in the cover letter for suggestions
accordingly.
> > Signed-off-by: Sagar Shrikant Kadam <sagar.kadam at sifive.com>
> > ---
> > arch/riscv/Kconfig | 6 +-
> > arch/riscv/cpu/generic/Kconfig | 12 ---
> > arch/riscv/cpu/generic/Makefile | 6 --
> > arch/riscv/cpu/generic/cpu.c | 35 -------
> > arch/riscv/cpu/generic/dram.c | 37 -------
> > arch/riscv/cpu/u54-mc/Kconfig | 12 +++
> > arch/riscv/cpu/u54-mc/Makefile | 6 ++
> > arch/riscv/cpu/u54-mc/cpu.c | 35 +++++++
> > arch/riscv/cpu/u54-mc/dram.c | 37 +++++++
> > arch/riscv/include/asm/arch-fu540-c000/clk.h | 14 +++
> > arch/riscv/include/asm/arch-generic/clk.h | 14 ---
> > board/sifive/fu540/Kconfig | 49 ----------
> > board/sifive/fu540/MAINTAINERS | 9 --
> > board/sifive/fu540/Makefile | 5 -
> > board/sifive/fu540/fu540.c | 139 ---------------------------
> > board/sifive/hifive_unleashed/Kconfig | 52 ++++++++++
> > board/sifive/hifive_unleashed/MAINTAINERS | 9 ++
> > board/sifive/hifive_unleashed/Makefile | 5 +
> > board/sifive/hifive_unleashed/fu540.c | 139 +++++++++++++++++++++++++++
> > configs/hifive_unleashed_defconfig | 11 +++
> > configs/sifive_fu540_defconfig | 11 ---
> > include/configs/hifive_unleashed.h | 47 +++++++++
> > include/configs/sifive-fu540.h | 47 ---------
> > 23 files changed, 370 insertions(+), 367 deletions(-)
> > delete mode 100644 arch/riscv/cpu/generic/Kconfig
> > delete mode 100644 arch/riscv/cpu/generic/Makefile
> > delete mode 100644 arch/riscv/cpu/generic/cpu.c
> > delete mode 100644 arch/riscv/cpu/generic/dram.c
>
> It looks that you did not use "git mv" command.
>
I do remember using "git mv" here. Probably adding '-M' (detect renames)
switch to git format-patch would have helped to include the renamed files
instead of delete and create information. Next time I will ensure to include it.
Thanks for pointing this.
BR,
Sagar Kadam
> > create mode 100644 arch/riscv/cpu/u54-mc/Kconfig
> > create mode 100644 arch/riscv/cpu/u54-mc/Makefile
> > create mode 100644 arch/riscv/cpu/u54-mc/cpu.c
> > create mode 100644 arch/riscv/cpu/u54-mc/dram.c
> > create mode 100644 arch/riscv/include/asm/arch-fu540-c000/clk.h
> > delete mode 100644 arch/riscv/include/asm/arch-generic/clk.h
> > delete mode 100644 board/sifive/fu540/Kconfig
> > delete mode 100644 board/sifive/fu540/MAINTAINERS
> > delete mode 100644 board/sifive/fu540/Makefile
> > delete mode 100644 board/sifive/fu540/fu540.c
> > create mode 100644 board/sifive/hifive_unleashed/Kconfig
> > create mode 100644 board/sifive/hifive_unleashed/MAINTAINERS
> > create mode 100644 board/sifive/hifive_unleashed/Makefile
> > create mode 100644 board/sifive/hifive_unleashed/fu540.c
> > create mode 100644 configs/hifive_unleashed_defconfig
> > delete mode 100644 configs/sifive_fu540_defconfig
> > create mode 100644 include/configs/hifive_unleashed.h
> > delete mode 100644 include/configs/sifive-fu540.h
> >
>
> Regards,
> Bin
More information about the U-Boot
mailing list