[U-Boot] Possible bug in imx6ul nand

Michael Nazzareno Trimarchi michael at amarulasolutions.com
Wed Jun 19 07:40:55 UTC 2019


On Wed, Jun 19, 2019 at 9:33 AM Shyam Saini <shyam at amarulasolutions.com> wrote:
> Hello Everyone,
> I tried to run "nand erase.part" and "nand erase.chip" on imx6ul isiot
> board and it hangs up and after some time it starts to give this error
> message:
> MXS NAND: DMA read error
> MXS NAND: Error sending command

Di di you check pinmux on the bus? I think that is not muxed. You are
booting from mmc
and the bootrom just not configure it because your boot sequence is prio on mmc


> I printed error number which was -110, did anybody else face this problem?
> I did try to erase nand with "flash_erase" from linux and it worked
> with throwing any error. In and all it seems like a uboot issue.
> Thanks a lot,
> Shyam

| Michael Nazzareno Trimarchi                     Amarula Solutions BV |
| COO  -  Founder                                      Cruquiuskade 47 |
| +31(0)851119172                                 Amsterdam 1018 AM NL |
|                  [`as] http://www.amarulasolutions.com               |

More information about the U-Boot mailing list