[U-Boot] [PATCH 09/18] autoboot: Drop #ifdef CONFIG_AUTOBOOT_KEYED
Simon Glass
sjg at chromium.org
Sun May 5 21:53:33 UTC 2019
At present we have two functions named __autoboot() which do different
things. This is confusing. Fix it by using if() instead of #ifdef for
selecting the functions, and renaming them to meaningful names.
Signed-off-by: Simon Glass <sjg at chromium.org>
---
common/autoboot.c | 17 ++++++++---------
1 file changed, 8 insertions(+), 9 deletions(-)
diff --git a/common/autoboot.c b/common/autoboot.c
index 45df6656760..012dd5797e1 100644
--- a/common/autoboot.c
+++ b/common/autoboot.c
@@ -35,8 +35,6 @@ static int stored_bootdelay;
#define AUTOBOOT_STOP_STR_SHA256 ""
#endif
-#if defined(CONFIG_AUTOBOOT_KEYED)
-
/*
* Use a "constant-length" time compare function for this
* hash compare:
@@ -203,7 +201,7 @@ static int passwd_abort_key(uint64_t etime)
* Watch for 'delay' seconds for autoboot stop or autoboot delay string.
* returns: 0 - no key string, allow autoboot 1 - got key string, abort
*/
-static int __abortboot(int bootdelay)
+static int abortboot_key_sequence(int bootdelay)
{
int abort;
uint64_t etime = endtick(bootdelay);
@@ -226,13 +224,11 @@ static int __abortboot(int bootdelay)
return abort;
}
-# else /* !defined(CONFIG_AUTOBOOT_KEYED) */
-
#ifdef CONFIG_MENUKEY
static int menukey;
#endif
-static int __abortboot(int bootdelay)
+static int abortboot_single_key(int bootdelay)
{
int abort = 0;
unsigned long ts;
@@ -277,14 +273,17 @@ static int __abortboot(int bootdelay)
return abort;
}
-# endif /* CONFIG_AUTOBOOT_KEYED */
static int abortboot(int bootdelay)
{
int abort = 0;
- if (bootdelay >= 0)
- abort = __abortboot(bootdelay);
+ if (bootdelay >= 0) {
+ if (IS_ENABLED(CONFIG_AUTOBOOT_KEYED))
+ abort = abortboot_key_sequence(bootdelay);
+ else
+ abort = abortboot_single_key(bootdelay);
+ }
if (IS_ENABLED(CONFIG_SILENT_CONSOLE) && abort)
gd->flags &= ~GD_FLG_SILENT;
--
2.21.0.1020.gf2820cf01a-goog
More information about the U-Boot
mailing list