[U-Boot] [PATCH 2/2] rockchip: px30: Add support for using UART3 as debug UART

Heiko Stuebner heiko.stuebner at theobroma-systems.com
Thu Nov 28 09:44:17 UTC 2019


On 27.11.19 11:12, Paul Kocialkowski wrote:
> Some generic PX30 SoMs found in the wild use UART3 as their debug output
> instead of UART2 (used for MMC) and UART5.
>
> Make it possible to use UART3 as early debug output, with the associated
> clock and pinmux configuration. Two sets of output pins are supported (M0/M1)
> so a Kconfig option to select between the two is introduced like it's done
> for UART2.
>
> Future users should also note that the pinmux default in the dts is to use
> the M1 pins while the Kconfig option takes M0 as a default.
>
> Signed-off-by: Paul Kocialkowski <paul.kocialkowski at bootlin.com>

Reviewed-by: Heiko Stuebner <heiko.stuebner at theobroma-systems.com>

with one small question below

> diff --git a/arch/arm/mach-rockchip/px30/Kconfig b/arch/arm/mach-rockchip/px30/Kconfig
> index 109a37be15ad..167517bbd63f 100644
> --- a/arch/arm/mach-rockchip/px30/Kconfig
> +++ b/arch/arm/mach-rockchip/px30/Kconfig
> @@ -36,6 +36,15 @@ config DEBUG_UART2_CHANNEL
>   	  For using the UART for early debugging the route to use needs
>   	  to be declared (0 or 1).
>   
> +config DEBUG_UART3_CHANNEL
> +	int "Mux channel to use for debug UART3"
> +	depends on DEBUG_UART_BOARD_INIT
> +	default 0
> +	help
> +	  UART3 can use two different set of pins to route the output.
> +	  For using the UART for early debugging the route to use needs
> +	  to be declared (0 or 1).
> +
>   source "board/rockchip/evb_px30/Kconfig"

Would it make sense to rename DEBUG_UART3_CHANNEL to just
DEBUG_UART_CHANNEL and reuse it, so that we don't collect similar
options for each uart?

Heiko



More information about the U-Boot mailing list