[PATCH 1/3] mips: mt76x8: ddr_cal: Rename dqs_test_valid() to dqs_test_error()

Stefan Roese sr at denx.de
Wed Apr 15 09:46:57 CEST 2020

Hi Weijie,

thanks for reviewing. Could you please also review the latest RFC
version of my "generification" of the legacy lzma support as well?
I really would like to see some review comments before sending v7
of this patchset to get it (hopefully) accepted in this merge window.



On 15.04.20 09:19, Weijie Gao wrote:
> On Fri, 2020-03-06 at 15:14 +0100, Stefan Roese wrote:
>> This function returns "-1" (true) upon error. So the function name does
>> not match its implementation which is confusing. This patch renames the
>> function to dqs_test_error() which makes the code easier to read.
>> Also change the return type to bool and return "true" or "false".
>> Signed-off-by: Stefan Roese <sr at denx.de>
>> Cc: Weijie Gao <weijie.gao at mediatek.com>
>> Cc: Daniel Schwierzeck <daniel.schwierzeck at gmail.com>
>> ---
>>   arch/mips/mach-mtmips/ddr_cal.c | 12 ++++++------
>>   1 file changed, 6 insertions(+), 6 deletions(-)
> Reviewed-by: Weijie Gao <weijie.gao at mediatek.com>

Viele Grüße,

DENX Software Engineering GmbH,      Managing Director: Wolfgang Denk
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-51 Fax: (+49)-8142-66989-80 Email: sr at denx.de

More information about the U-Boot mailing list